Hi Gabrielle,
 
I just tested Tomcat 4.0.6 standalone without certificates,
and non-administrators can submit to collections.  The only
requirement is that the user must be in a group with 'ADD'
permission to a collection.
 
To test this, I
 
1) created a 'Test Community'
2) created a 'Test Collection' (id=10)
3) created an EPerson dstuve@mit.edu
4) created a group collection_10_add
5) added dstuve@mit.edu to the group
6) added policy 'anonymous' READ to 'Test Collection'
7) added policy 'collection_10_add' ADD to 'Test Collection'
 
8) Then tried to log in, clicked 'click here to register'
9) Gave my email address, went to email and clicked on register link
10)Got back onto DSpace, chose submit, logged in and submitted
 
Good luck - either something is wrong and the EPerson isn't
logging in, or the ADD permission isn't set.
 
Dave
 
-----Original Message-----
From: Horan, Gabrielle [mailto:Gabrielle.Horan@IUE.it]
Sent: Thursday, March 27, 2003 8:28 AM
To: dspace-tech@lists.sourceforge.net
Subject: [Dspace-tech] Authorisation to submit to a collection

 
We have installed a pilot version of DSpace on our intranet.
 
For testing purposes it is running with Tomcat 4.0.6 WITHOUT Apache and WITHOUT Client certificates.
 
We have set up some test sequences in order to try to understand the authorisation architecture.
 
The ADMIN user interface is easy to use and it is quite self explanatory, however relating to the authorisation I have at least one very specific question.
 
Can anyone tell us, what is reuired in order to give an egroup access to submit articles to a collection.
 
We have tried the following:
Create a new collection  called Working papers without workflows
Create a group called submitters and added a user Gabrielle.horan@iue.it
Give anonymous access to read.
Give read, write, add, remove, delete access to a group called Submitters
 
Trying to submit as user Gabrielle.horan@iue.it gives the "authorisation failed" message,
 
./error/authorize.jsp

AS adminsistrator this can be done without any problem... But should only administrators be able to submit??

 

We  are currently troubleshooting the problem, and looking in all directions, but if someone could help point us in the right direction it would be greatly appreciated.

 

Thanks and regards,

Gabrielle Horan.