Hello,

 

I am trying to install DSpace onto our server and it is not letting me create a user or database through PostgreSQL.  I’ve tried installing different versions of Postgre.  I’ve tried changing the ports and host IP addresses. 

 

Also, PostgreSQL service will not start consistently.  Often times, it would not start.  It would say sometimes services will not start unless they had something to do.  However, when I attempt to give it something to do through command promp, it says “Createuser: could not connect to database postgres: server closed the connection unexpectedly.  This probably means the server terminated abnormally before or while processing the request.” In addition, when I go through the PGadmin program and I start the database, it says the server is not listening, although our firewall is turned off and it is set to listen to all IPs.

 

Event viewer says \"could not open process token: error 5\" every time I attempt to start the service via Services window and command prompt.  I\'ve uninstalled and installed Postgres about 10 times.  Everything else seems to be working properly until that part of the installation instructions.

 

Warm regards,

 

Chichi Lu

Network Systems Specialist

Information Technology Department

Bahá'í National Center

1233 Central St.

Evanston, IL 60201

(847) 733-3422

CLu@usbnc.org

 

"We cannot be casual Bahá'ís.  Even if we only have a crumb to give we must not withhold it." --Dorothy Baker