I have removed the "/" from provider_url, it is still not working. I have even tried the latest version DSpace 3.2 Snaphsot build. Still getting the same problem. Any other suggestion or idea to at least debug it or trace what is actually happening. I don't know even if it is reading the authentication-ldap.cfg or not. I placed the break points using Netbeans where these modules are loaded but it does not stop there.

Sent from Alto - altomail.com

-----Original Message-----

From: dale.poulter@vanderbilt.edu<dale.poulter@vanderbilt.edu>
To: lifeh2o@gmail.com<lifeh2o@gmail.com>,dspace-tech@lists.sourceforge.net<dspace-tech@lists.sourceforge.net>
Sent: Friday, February 15, 2013
Subject: RE: [Dspace-tech] LDAP is not enabling

When you defined the provider_url in the authentication-ldap.cfg did you include the trailing “/” ? This was an issue that we encountered.

From: lifeh2o@gmail.com [mailto:lifeh2o@gmail.com]
Sent: Friday, February 15, 2013 4:38 AM
To: dspace-tech@lists.sourceforge.net
Subject: [Dspace-tech] LDAP is not enabling

I have added [org.dspace.authenticate.LDAPAuthentication] above password plugin in [authenticaiton.cfg] and also set [enable=true]

Now the chooser.jsp appears, but when I click LDAP login from chooser, on the next [ldap-login] page. The password form appears.

boolean ldap_enabled = ConfigurationManager.getBooleanProperty("ldap.enable");
returns false no matter what has been set in authenticaiton-ldap.cfg

Sent from Alto - altomail.com