We tried
1. DSpace 3.0 from Github
2. DSpace 3.1 from Github
3. DSpace 3.2 snapshot from Github
4. DSpace 3.0 from Sourceforge

We also tried configuring ONLY these settings
build.properties -->
dspace.install.dir = C:/dspace

dspace.cfg -->
dspace.url = ${dspace.baseUrl}/jspui

authentication.cfg -->
plugin.sequence.org.dspace.authenticate.AuthenticationMethod = \
org.dspace.authenticate.LDAPAuthentication, \
org.dspace.authenticate.PasswordAuthentication

authentication-ldap.cfg -->
enable = true


But in all these cases, the chooser page is enabled where we can choose to login using LDAP or Password. But when we click on LDAP link to use LDAP login method, the password page is loaded instead. And while debugging we found that ldap_enabled is being returned false.
LDAPServlet.java -->
boolean ldap_enabled = ConfigurationManager.getBooleanProperty("ldap.enable");

We can not find the code where authentication-ldap.cfg is being loaded so that we can check if it is even being loaded or not, or if it is being parsed correctly or not.



Sent from Alto - altomail.com




From: helix84@centrum.sk<helix84@centrum.sk>
To: lifeh2o@gmail.com<lifeh2o@gmail.com>
cc: <dale.poulter@vanderbilt.edu>,<dspace-tech@lists.sourceforge.net>
Sent: Tuesday, February 19, 2013
Subject: Re: [Dspace-tech] LDAP is not enabling

Based on a quick look, the mistake might be that there is a space
before this property:

id_field = uid


Regards,
~~helix84

Compulsory reading: DSpace Mailing List Etiquette
https://wiki.duraspace.org/display/DSPACE/Mailing+List+Etiquette