Hi,

 

This is question for Repository Tools for Dspace.

I wonder if anybody has faced this problem with Dspace upgrade.

 

We got Repository Tools for Dspace to talk to Symplectic Elements (Publication website).

 

We have upgraded our Dspace instance from 1.6.2 to 1.7.2 but the upgrade has broken the Repository Tools.

 

What is the best way of fixing the Repository Tools?

 

Do we need to install Repository Tools again after the upgrade?

 

Or

 

Do we just need to compile Dspace with following jars?

dspace-symplectic-api

dspace-symplectic-webapp

elements-api

 

I have copied our old crosswalk and the publication settings in dspace.cfg  in new installation directory.

 

The exception in the dspace.log is:

 

Caused by: java.lang.ClassNotFoundException: uk.co.symplectic.repository.dspace.ElementsConsumer

        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1645)

        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1491)

        at java.lang.Class.forName0(Native Method)

        at java.lang.Class.forName(Class.java:169)

        at org.dspace.event.ConsumerProfile.readConfiguration(ConsumerProfile.java:87)

        at org.dspace.event.ConsumerProfile.makeConsumerProfile(ConsumerProfile.java:62)

        at org.dspace.event.EventManager$DispatcherPoolFactory.makeObject(EventManager.java:227)

 

 

Regards

Kirti Bodhmage

Application Analyst