Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

drPython under RH9 -- init failure

Help
fyngyrz
2004-12-20
2013-04-26
  • fyngyrz
    fyngyrz
    2004-12-20

    Just installed drPython. Using python 2.2.2; wxPython installed, runs fine. drPython stops on initialization with the following error...

    Traceback (most recent call last):
      File "./drpython.pyw", line 36, in ?
        app = drpython.DrApp(0)
      File "/usr/lib/python2.2/site-packages/wxPython/wx.py", line 1951, in __init__    _wxStart(self.OnInit)
      File "./drpython.py", line 3843, in OnInit
        self.frame = DrFrame(None, 101, "DrPython - Untitled 1")
      File "./drpython.py", line 767, in __init__
        self.InitializeConstants()
      File "./drpython.py", line 1724, in InitializeConstants
        self.STCCOMMANDLIST = drShortcuts.GetSTCCommandList()
      File "./drShortcuts.py", line 165, in GetSTCCommandList
        return [wx.stc.STC_CMD_BACKTAB, wx.stc.STC_CMD_CANCEL, \ AttributeError: 'module' object has no attribute 'STC_CMD_CHARLEFTRECTEXTEND'

    ...darned if I know what it all means, but it doesn't run, anyway. Any help would be appreciated.

     
    • Hm, what wxPython version do you have installed?
      I suppose, when you have Pyhton 2.2.2,
      you also have an older wxPython (2.4?)).
      At any rate, you need wxPython at least
      2.5.2.7 or higher and Python 2.3.

      wxPython Demo is running?
      Help => About

      Franz

       
    • fyngyrz
      fyngyrz
      2004-12-20

      Hmmm. I have no information about a demo of wxPython. I ran pydoc on wxPython.wx but the results showed no version information I could spot. Originally, I did...

          apt-get install wxPython

      ...and it did. I don't know where it put it, "man wxPython" and "info wxPython" get me nothing, but I was able to code up the examples from the wxPython site and build a window with menus, so I know it is there.

      Just now, I did...

          apt-get --reinstall install wxPython

      ...and it reinstalled, but I didn't see apt-get download new information, so I presume that it thinks I should have the version that I have now, based on (perhaps) my version of python. So...

      I tried to install a new python with...

          apt-get --reinstall install python

      ...but the RPM command driven by apt-get returned 1, meaning it failed to install the package. No information as to why, it just failed. !@&^%#@.

      <RANT>
      Linux drives me nuts with its crazy quilt of dependencies. One of the most brutal downsides of OSS is that most of this stuff does not supply an even marginally reasonable installation mechanism. One that doesn't just break, like apt-get did for python, or fail without warning like drPython did and the install.py in the drPython directory did, or even says "you need this, that or the other thing" (even that would be a luxury compared to the junk I'm running into here) but instead goes and GETS what you need and installs it and just plain works.
      </RANT>

       
    • Heh.  Perhaps you should try Debian, or a debian based distro like Ubuntu or Mepis, or heck, even Mandrake.  Failed dependency madness is nuts.

      Anywho,

      Your version of python should be fine.  The traceback points to an error in the styled text control in wxpython.

      This is curious, but it is possible that the wxpython version you installed is corrupt in some way.

      So here is my suggestion:

      First, it is possible the reinstall for python is failing because you have packages installed that depend on it (I am probably wrong, but I seem to remember stuff like that with apt-get).

      Given that apt-get is returning such an old version of python (2.2), you are probably not getting the latest greatest wxpython (just a hunch).

      run python as a sanity check from a terminal, and see if it is still there (/usr/lib/python2.2, I'd suppose).

      Assuming it is, uninstall wxpython, and download wxPython 2.5.2.8:  http://prdownloads.sourceforge.net/wxpython/wxPythonGTK-py2.2-2.5.2.8-RH9.i386.rpm?download

      This should be the right link.

      Then download this:  http://prdownloads.sourceforge.net/wxpython/wxPythonDemo-2.5.2.8.tar.gz?download

      untar it someplace clever, and run demo.py (in the demo subdirectory).

      How does that work?

      Now try drpython.

      You should be good to go.

      Cheers,
      Dan

       
    • fyngyrz
      fyngyrz
      2004-12-21

      That did it, thank you very much. drPython seems to be working just fine.

      The demo program is also very impressive -- I'm feeling more than a bit floored, and encouraged as well. :)

      I'll make sure you get a few bucks for your Mac. :)

      fyngyrz
      (Ben)

       
    • Huge Thanks for the moolah

      I'm glad you got stuff up and running,
      the demo is very impressive.  The best part is pretty much everything runs the same way on windows and on the mac.