Installing DrPython

Help
zach
2006-11-13
2013-04-26
  • zach
    zach
    2006-11-13

    I'm a novice with programming and I have just started to learn Python. I found about DrPython and downloaded the zip and unzipped to c:\drpython-161

    I'm on Windows XP and already have installed Python25(under C:\python25) and Wxpython (C:\Python25\Lib\site-packages\wx-2.7.2-msw-unicode\wxPython). When I double click on drpython.pyw A small Window opens giving me the choice of Beginner and Advanced.

    However, when I click on either one of them nothing happens. I then opened the drpython.pyw using IDLE and ran the code in the file and I get the following error messages:

    Traceback (most recent call last):
      File "C:\drpython-161\drpython.pyw", line 36, in <module>
        app = drpython.DrApp(0)
      File "C:\Python25\Lib\site-packages\wx-2.7.2-msw-unicode\wx\_core.py", line 7749, in __init__
        self._BootstrapApp()
      File "C:\Python25\Lib\site-packages\wx-2.7.2-msw-unicode\wx\_core.py", line 7346, in _BootstrapApp
        return _core_.PyApp__BootstrapApp(*args, **kwargs)
      File "C:\drpython-161\drpython.py", line 3922, in OnInit
        self.frame = DrFrame(None, 101, "DrPython - Untitled 1")
      File "C:\drpython-161\drpython.py", line 560, in __init__
        self.ShowSourceBrowser()
      File "C:\drpython-161\drpython.py", line 3237, in ShowSourceBrowser
        self.SourceBrowser = drSourceBrowserPanel(target, -1, self.prefs.sourcebrowserpanel, i)
      File "C:\drpython-161\drSourceBrowser.py", line 175, in __init__
        self.Position = Position
      File "C:\Python25\Lib\site-packages\wx-2.7.2-msw-unicode\wx\_core.py", line 8374, in Move
        return _core_.Window_Move(*args, **kwargs)
    TypeError: Expected a 2-tuple of integers or a wxPoint object.

    What am I doing wrong? Is it that the versions of Python or WxPython are not compatible with DrPython?

    Any help will be appreciated.

    Thanks

    zachsree

     
    • Hello zachsree,
      I write instead of Dan (Project leader).

      You do nothing wrong, you are not the first one, who reports this.
      I try to contact Dan. Maybe he could correct that error, but I cannot
      promise.
      See also:
      http://aspn.activestate.com/ASPN/Mail/Message/3312638

      I am for myself on Win XP, wxPy 2.6 (ansi) and Python 2.4.
      Robin Dunn changed something in wxPy 2.7 and it isn't compatible anymore.

       
    • Roberto
      Roberto
      2007-01-01

      Hi Zachsree:

      If you haven't tried it yet, you might want to un-install the version161 version.  The download and install the latest version of DrPython v163.  Here's the link:

        (http://sourceforge.net/project/showfiles.php?group_id=83074)

      I installed Dr. Python on Windows XP and along with Python 25 and wxPython 2.8.0.1  Seems to be working fine.

      Cheers

       
    • Hello Roberto,

      yes wxPython 2.6 and 2.8 is a kind of incompatible.