#106 gnome-documents doesn't start

dlg-3.10
new
Eugen Wissner
desktop
normal
3.10.1
crash
2014-03-24
2014-02-13
Eugen Wissner
No

gnome-documents x86-64 doesn't start (i686 works). Output from the console:

Message: JS WARNING: [/usr/share/gnome-documents/js/documents.js 764]: octal literals and octal escape sequences are deprecated
Message: JS WARNING: [/usr/share/gnome-documents/js/documents.js 764]: octal literals and octal escape sequences are deprecated
** Message: JS WARNING: [/usr/share/gnome-documents/js/documents.js 764]: octal literals and octal escape sequences are deprecated
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Discussion

  • brokenman
    brokenman
    2014-03-14

    I am also seeing this. Starting with: dbus-launch gnome-documents yields more info.

     
  • casaxa
    casaxa
    2014-03-14

    Since I have no idea why on x86-64 it does not work I have filled up a bug on gnome bugzilla.

    Here is the link: https://bugzilla.gnome.org/show_bug.cgi?id=726382

    I suspect is something to do with the gcr build.

     
  • brokenman
    brokenman
    2014-03-17

    Downgrading gjs to 1.38.0 (match gobject version) got me an interface. I had also recompiled some other packages so just need to do some testing to make sure.

    EDIT: Yes downgrading gjs brings up the gnome-documents interface. Run from terminal, ctrl +c and run again. Sadly it has no functionality and no documents show up.

     
    Last edit: brokenman 2014-03-17
  • brokenman
    brokenman
    2014-03-19

    I was able to get the interface up without downgrading gjs. Here is the process i took:

    itstool-1.2.0-x86_64-1
    nspr-4.10.3-x86_64-1jay (upgraded)
    Recompiled gnome-documents 3.10.2
    Recompiled gobject-introspection-1.38.0-x86_64-1jay
    Recompiled tracker-0.16.4-x86_64-1jay
    Recompiled gjs-1.38.1-x86_64-1jay
    Run: tracker-control -rs

    Various other packages were recompiled but only to include the missing .la files. After this i get the gnome-documents interface up but it does not show any documents despite tracker monitoring my home directory containing PDF documents.

    In 3.8.x I had gnome-documents working nicely. It only took recompiling gobject, then tracker, then gjs. In 3.10.x I have no working gnome-documents in both 32 and 64bit. Hope this helps in some way.

     
    Last edit: brokenman 2014-03-19
  • casaxa
    casaxa
    2014-03-19

    Many thanks Jay, I will wait to see if we get some more info from gnome.org devs. What seems strange to me is the JS ERROR: Error: Unsupported type void,
    deriving from fundamental void, which in my opinion has something to do with the gnome stuff. Now, since i have no idea about java programming or javascript I have no idea on where to start debugging. It is good you made it partially work. From the packages you recompile I see that we can maybe have some problem also with the mozilla stuff.

     
  • brokenman
    brokenman
    2014-03-22

    I finally have it working. It seems it required gnome-online-miners in order to see the online documents. It is still not seeing local documents however.

    https://download.gnome.org/sources/gnome-online-miners/3.10/

     
  • casaxa
    casaxa
    2014-03-24

    Glad to hear you made it work, but to be honest this is not the right solution for us, as it really needs to work with local files.