Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#346 XFree86-4.0.3 + MGA + DRI can't load tex

Other
closed
nobody
MGA OpenGL (56)
5
2003-01-13
2001-05-30
Anonymous
No

I currently use Debian GNU/Linux + Kernel-2.4.4 +
XFree-4.0.3 + DRI-0.7 (with Extras).
When I try to launch some applications like
"glplanet", I get an error message :
"texture error: invalid value".

Generally speaking, I have texture problems with many
OpenGL applications using textures (including Quake
III,...)

Discussion

  • Logged In: NO

    I forgot to tell you that I'm using a Matrox G200 with
    Rainbow Runner extension card and 8 Mo of SDRAM.
    Other OpenGL applications not using textures (Gears,
    blender,...) work correctly and accelerated without a
    problem...

     
  • Eric Anholt
    Eric Anholt
    2003-01-12

    Logged In: YES
    user_id=7685

    What resolution and depth are you using? Is this still a
    problem?

     
  • Thierry FLORAC
    Thierry FLORAC
    2003-01-13

    Logged In: YES
    user_id=32092

    Hi,

    this (old !) problem was solved a long time ago, when I
    switched to XFree-4.1.x and, in fact, when I switched my
    screen color depth from 16bpp to 24bpp.

    Everything works fine, now !!

    Thanks anyway, for your support and your good work...

    Thierry

     
  • Eric Anholt
    Eric Anholt
    2003-01-13

    • status: open --> closed