#110 script errors after installing firefox 0.9.2

closed
nobody
None
5
2005-01-25
2004-07-16
Anonymous
No

i've just upgraded from mozilla firefox 0.8 to 0.9.2 and
get the following errors:

i get "Internet Explorer Script Error" windows with the
following messages, asking if i'd like to continue running
scripts on the page. clicking yes or no seems to make
no difference. i'm using IE6, patched with all the current
critical updates.

upon booting windows i get an error window with-

an error has occurred on this page.
line: 262
char: 7
error: unspecified error
code: 0
URL: (search.html in the dir i installed the search bar
into)

when clicking in the text box to type a search-

line: 716
char: 3
error: 'init' is undefined
code: 0
URL: as above

this one i seemed to "fix" by adding the line 'init = false'
right before line 716, but i don't know what overall
effect that'll have.

and finally, when i click on the magnifying glass graphic
on the QSDB-

line 376
char 3
error: 'reuseBrowserWindowModeOverride' is undefined
code 0

i assume firefox to be the culprit as i made a norton
ghost image of my hdd prior to installing it (lucky eh!). i
reverted back to that image and tried installing firefox
again, without making any other changes anywhere on
my system, and the same thing happened. before
installing firefox 0.9.2 i tried firstly renaming the old
firefox folder to something else (without uninstalling),
and the second time i completely uninstalled firefox 0.8
before installing 0.9.2. no difference it seems.

sorry if there's already a tracker for this but i checked
and couldn't see one. any help would be much
appreciated! i'd like upgrade firefox but i'd also like to
continue using this excellent and very handy search
tool :)

my email address is grindcore0@hotmail.com

Discussion

  • Logged In: NO

    sorry, forgot to mention: i'm running version 3.1.8 :)

     
  • Logged In: NO

    sorry, forgot to mention: i'm running version 3.1.8

     
  • OverloadUT
    OverloadUT
    2004-07-20

    Logged In: YES
    user_id=1005121

    I am also running DQSD 3.1.8.0 and Firefox 0.9 and I see the
    same problem.

    It almost makes DQSD unusable, as the time I save is lost by
    needing to close the script error every time. Plus, when the
    script error occurs, the search is not stored in the DQSD
    history, making F8 useless. :(

     
  • Will Dean
    Will Dean
    2004-07-20

    Logged In: YES
    user_id=130313

    I saw this problem about a month ago (when FF 0.9) first
    came out. I've fixed (worked-around, really) this with some
    mods to tools.js.

    I've just committed these changes to the CVS repository.

    The next release will have this in. Before that, you'll
    need to obtain a copy of the tools.js and replace your
    existing one with that.

     
  • Kim Gräsman
    Kim Gräsman
    2004-07-21

    Logged In: YES
    user_id=551308

    This seems to be partly a problem with Mozilla:
    http://bugzilla.mozilla.org/show_bug.cgi?id=246078

    There's a workaround posted as an attachment to the bug report.

    Together with Will's fixes, I think this should do it - I'm
    running Firefox at the moment, and it appears to be working OK.

     
  • don kretz
    don kretz
    2004-07-25

    Logged In: YES
    user_id=816078

    It appears to be incomplete assignment by Windows of any
    browser (not just mozilla) as the default application for html
    etc. files. I just resolved the problem on my PC by running

    http://www.pc-tools.net/win32/freeware/setbrowser/

     
  • Shawn K. Hall
    Shawn K. Hall
    2005-01-25

    • status: open --> closed