Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

doszip commander + samba

Help
2010-01-11
2012-12-07
1 2 > >> (Page 1 of 2)
  • Hi
    I have set freedos with msclient 3.0. MSclient is needed for connecting freedos clients to my samba server.
    All work fine. My next step was a choosing file manager for users. And i have choosed DZ because it s lightweight and freeware.
    But one thing have disappointed me: DZ cannot copy files to/from disks which are mapped from samba.  I can copy files from command line by typing:

    copy <local disk>\files <network disk>\files
    

    and I can do it from VC(volcov commander).
    When I start to copy  file from local disk to network disk an error occurs:

    Can't open the file
    <my file>
    Invalid argument
    

    The same error occurs when I try copying from network disk to local.
    Who met such problem?
    Bye

     
  • Sorry i have forgot something to say.
    Versions of dz (which i tried) are 1.38 to 1.41.
    And all versions cant copy to/from network disks.

     
  • I cannot reproduce this problem, so I have no way of testing this at the moment.

    Nidud

     
  • Hi

       But do you have any thoughts about this?
       I have tested DZ yesterday and i have seen that it can create directories and delete files in network disks.  I dont understand problem with copying from/to network disk.
       Can you explain when such event

    Can't open the file
     <my file>
     Invalid argument
    

    occurs ?

    Bye

     
  • Is the filename <my file> correct in the message window?

    By disable the use of long filenames (Configuration->System),
    those it still occur?

     
  • Hi
      Answer about filename in the message window:
      
      For example if i copy local  file (c:\doc\test.txt) to network disk (*s:\public*) next message will occur

      Can't open the file
      s:\public\text.txt
      Invalid Argument
    

             
      I have disabled use long file names in DZ but error occurs still.
    Bye

     
  • If you try to copy s:\public\text.txt to c:\doc\text.txt, do you get the same message?
    Meaning, is both read and write access a problem, or is it then c:\doc\text.txt that is displayed in the message window?

    Is it possible to use F3 to view the content of s:\public\text.txt?

     
  • I can copy from command line to/from network disks. It means i can type

    copy s:\public\text.txt to c:\doc\text.txt
    

    and copying will occur.
    It does not possible to use F3 to view content of s:\public\text.txt.

     
  • I think the problem is the way Doszip open files:

    Doszip use the INT 21 - DOS 4.0+ - EXTENDED OPEN/CREATE:
    - The PC LAN Program only supports existence actions of 01h, 10h - Doszip use 00h
    - This function has bugs when used with drives handled via the network redirector

    The values for DOS extended error code, which gives an "Invalid Argument":
    01h (1) function number invalid
    06h (6) invalid handle
    0Ch (12) access code invalid
    0Dh (13) data invalid
    57h (87)  (DOS 3.3+) invalid parameter

    I assume it is the 12 or 87 in this case.

    Not shore why this function is used, but you could try
    to use the DOSLFN program that comes with FreeDOS.
    This should bypass the function above.

    nidud

     
  • Hi
        I have tried to use DOSLFN program that comes with FreeDOS. But  I can't copy to/from network disks still.
        I have tried two times.
        First time i have used DZ with its own lfn +  DOSLFN that comes with FreeDOS.
        And second time I have used DZ without own lfn + DOSLFN that comes with FreeDOS.
    Bye

     
  • According to the specification the Microsoft Network Client for MS-DOS works with any version of MS-DOS between 3.2 and 6.22 inclusive; however, you may need to refer to the manufacturer of the network interface card (NIC) for the version of MS-DOS the NIC requires.

    Doszip is tested on network with MS-DOS 5.0+, and the functions mention above should also work with version 4.0.
    No network testing is done using FreeDOS or Samba software.

    In short, there is nothing I can do here since I have no way of testing this at the moment.

    Maybe you could try using Dos Navigator?
    This is also freeware, and it is available at http://www.ritlabs.com/dn/

    nidud

     
  • Some changes are made and some bugs removed so it may work now.
    The network issue is not tested, but related to the problems.

    nidud

     
  • Hi
       Great!
        I will test it today and post results here.
       Thank you.
    Bye

     
  • Hi
    I have tested dz 1.42  and it works!
    But it still have errors.
    I have tried to copy to/from network disks. it works but couple times at the end of copying i have got such error

    There was an error while copying
    'Data error (bad crc)'
    

    Also I have discovered a bug:

    Two events:

    first is a deleting empty folder on the local disk.
    second is a deleting folder on the local disk which contains files.

    FIRST EVENT
    When you delete an empty folder on the local disk, DZ first shows standart message about deleting

    Do you wish to delete <folder>
    

    After pressing "delete all" it shows strange message

    Do you wish to delete FREEDOS
    

    Then you press ok DZ will show message that means "there is no folder FREEDOS in <your path>" and delete empty folder.

    SECOND EVENT
    When you delete a folder which contains files on the local disk, DZ will show standart message about deleting

    Do you wish to delete <folder>
    

    After pressing "delete all" it shows strange message

    Do you wish to delete FREEDOS
    

    Then you press ok DZ will show message that means "there is no folder FREEDOS in <your path>" and not delete folder until it contains files.

    And one litte thing quantity of repetitions of this strange message depends on quantity of folders under deleting folder + deleting folder. It means that if you will delete folder which contains two sub folders, then the message about deleting file freedos appears three times.

    There is no such bug when i delete folders on network disk.

    Thank you for your attention.
    Bye.

     
  • There was a bug in the CRC test so the 'Data error (bad crc)' may be fixed now.

    nidud

     
  • Hi
        I have tested dz 1.43
        I have understood a nature of  CRC Error. 
        My freedos-clients print file on the printer.
        They press F5 and type in copy field  - PRN.
        Thus they send file to the printer.
        So if in the moment of sending file printer is stopped , 'bad crc' error will happens. Also it will happens if they temprorary stop  the printer in time of printing.
        Bug with deleting magic file FREEDOS is still live.
    Bye.

     
  • The CRC test is to make shore output data is equal to the input. In some cases the CRC test prohibit you from copy a file with error and it may be useful to skip this test (if you don’t care), so a “ Use CRC check on copy” option may be added.

    A bug was found in the OpenFile function, which creates a problem on overwriting an existing file.

    nidud

     
  • Found a bug in the read functions - it accepted a Volume ID as file.

    The magic file FREEDOS should now be gone.

    nidud

     
  • Hi
       Bug with magic file FREEDOS have disappeared. Great! Thank you.
       I have tested dz 1.45. And It works almost perfectly , but CRC error  disturbs users.
       Do i understand right: DZ dont have  option  “ Use CRC check on copy”  now, dont it?
       Can you add this option please?
    Bye

     
  • Hi
    I have thoughts about a CRC error. 
    In Volkov Commander when you try to send job to stopped printer It will show a message

      Error
    Error on Device PRN:
    Write Fault
    [RETRY]  [ABORT]
    

    Also It will show such message if you stop the printer in time of job printing.
    And You can simply press retry and VС wiil continue "copying" (sending data) to prn.
    Can you add such feature to DZ (handling CRC error like VC)?
    Bye

     
  • Dos the CRC error message still appear?
    The CRC test didn't work properly but this was fixed in v1.43.

    There is currently no Printing Service in DZ, but this may be added later.
    Using F5 to copy a file to LPT2 will only give a message if not installed.

    FreeDOS Edit (F4) may provide Printing Service for a single file.
    A tool to print multiple files may be added to the Alt-F5 dialog.

     
  • Hi
       Yes, It s still appear.
       Whad do you mean under term printing service?
       As I understand device PRN is provided by the freedos kernel and filemanagers  work  with it through some system calls. 
       I have tested DZ and it  can work with PRN - I can press F5 and copy(send) file to PRN.
       But if I in DZ stop the copying I will get CRC error.  And That is why i have remembered Volcov Commander which handling   such events like stopping the printer and printer is not plugged. it seems to me that VC can pause crc check or something like that.
    So the question is "can you do  this in DZ ?"
    Bye

     
  • I have tested the CRC functions and not found anything wrong there.
    There was however a mixup of messages in the error output and this have been corrected.

    This means that the error is still there, but now there will be (hopefully) another message.

    The Printer Service communicate with the printer during copy, testing if ready, out of paper and so on.
    The operating system provides a "file" (PRN, LPT1, LPT2) between the printer and the program.
    After data is sendt to this file the printing begin so there is no direct communication.

    > But if I in DZ stop the copying I will get CRC error.
    How do you stop the copy?

    > it seems to me that VC can pause crc check or something like that
    It communicate with the printer during copy.

    > can you do this in DZ ?
    No, you can't do this in DZ.

    > Can you add such feature to DZ
    Maybe in the future but not right now.

     
  • Hi

    How do you stop the copy?

    It s  industrial printer. it have a button STOP. if you press this button printer will stop printing.
    I have tested dz 1.46. and now  if i press stop, system error will occur:

    Error on device: PRN
    Arg list is too long
    Continue <hit enter to continue>
    

    Bye

     
  • The old Open-File functions did not allow opening of PRN but the new functions dos.
    A new set of error messages needed to be added, and this have now been corrected.

    A new error box is added (Device error) with  and .
    This is not a full "Print Service" but it will allow rewrite of data.

    Changelog:
    - fixed bug in System Error - wrong error messages
    - added some support for writing to a DEVICE - PRN and LPTX

     
1 2 > >> (Page 1 of 2)