#170 Shift key inserts

0.61
closed
5
2012-09-07
2004-02-04
Leon Roomberg
No

I installed DOSBOX on my WinMe system (2/4/2004).

I'm using a generic keyboard and do not believe I'm
using any special drivers other than whatever the
windows default is.

Upon executing DOSBOX, the prompt is:

    Z:>

When I key,

    C:\ [ENTER]

what is displayed is

    C1:\ Invalid Drive
      ^

!!!-----^

No matter what I do, the SHIFT key inserts a 1.

Unless someone has a work-around, this means I can't
use the product at all! (Cant' change directories...can't
run any

programs. Waaaaaa....)

This problem was noted as a separate problem (spanish
language) on the bottom of bug # 761672.

An old newsgroup article noted a problem
where "Unicode characters are being mapped to
wrong DOS characters." This may or may not be related.

Please help!

Thanks
Leon Roomberg
LeonRoomberg@yahoo.com
Phone 856.616.9543

Discussion

  • Peter Veenstra
    Peter Veenstra
    2004-02-05

    Logged In: YES
    user_id=535630

    well try setting your keyboard layout to US international if
    you haven't.
    Futher try replacing sdl.dll with other version.
    Dosbox only puts a 1 in the shell if it get's a key from sdl
    which it doesn't understand.

    To get dosbox running anyway. Put the commands you want to
    execute in dosbox.conf at the bottom.

     
  • Peter Veenstra
    Peter Veenstra
    2004-06-13

    Logged In: YES
    user_id=535630

    in The cvs the 1 - if key not recognised has been removed.
    Therefore this bug will be closed.