I'm on sourceforge. This email comes from Darwin, but I ran the code on Windows. I removed all the previous versions to make sure and then downloaded the newest snapshot:

cd docutils
python setup.py install
cd test
rst2xml.py --traceback  data/latin1.txt

Traceback (most recent call last):
  File "c:/Python32/Scripts/rst2xml.py", line 23, in <module>
    publish_cmdline(writer_name='xml', description=description)
  File "c:\Python32\lib\site-packages\docutils\core.py", line 352, in publish_cmdline
    config_section=config_section, enable_exit_status=enable_exit_status)
  File "c:\Python32\lib\site-packages\docutils\core.py", line 219, in publish
    output = self.writer.write(self.document, self.destination)
  File "c:\Python32\lib\site-packages\docutils\writers\__init__.py", line 81, in write
    output = self.destination.write(self.output)
  File "c:\Python32\lib\site-packages\docutils\io.py", line 393, in write
TypeError: 'str' does not support the buffer interface
Exception ValueError: 'I/O operation on closed file.' in <_io.TextIOWrapper name='<stdout>' mode='w' encoding='cp437'> ignored


rst2xml.py --output-encoding cp437 data/latin1.txt

gives no error.


On 10/1/12 3:30 AM, engelbert gruber wrote:
On Mon, Oct 1, 2012 at 5:02 AM, Paul Tremblay <paulhtremblay@gmail.com> wrote:
and gotten the same error.

python rst2xml.py --version

rst2xml.py (Docutils 0.9 [repository], Python 3.2.2, on win32)
should be::

  rst2xml.py (Docutils 0.10 [repository], Python 3.2, on darwin)

did you change the repository to sourceforge or are you still on berlios ?