#39 Not all subjects appearing in record display

closed-fixed
chickmarkley
Data (12)
8
2008-01-02
2007-11-26
Laura Akerman
No

Not all subjects in the MODS record are coming through to the record display. In the examples I've seen, only one of multiple subjects appears (and not the one I would have picked!).

Examples:

http://www.dlfaquifer.org/search/item/Song-of-the-Hebrew-captive/oai%253Alcoa1%252Eloc%252Egov%253Aloc%252Emusic%252Fsm1830%252E360170?q=sacred+harp
http://www.dlfaquifer.org/search/item/General-view-of-Los-Angeles-Olympic/oai%253Alcoa1%252Eloc%252Egov%253Aloc%252Epnp%252Fpan%252E6a28342?q=olympic+games http://www.dlfaquifer.org/search/item/Whatwuzit-The-1996-Atlanta-Summer-Olympics/oai%253Asspaces%253A7?q=olympic+games

Since this is a hyperlinked field, it would be good to have all the subjects hyperlinked, perhaps separated by semicolons as the multiple terms in Genre, Physical Description and perhaps other fields.

Discussion

1 2 > >> (Page 1 of 2)
  • Laura Akerman
    Laura Akerman
    2007-11-26

    Results with 1 subject

     
  • Laura Akerman
    Laura Akerman
    2007-11-26

    MODS with 2 subjects

     
    Attachments
  • Laura Akerman
    Laura Akerman
    2007-11-26

    Logged In: YES
    user_id=1887270
    Originator: YES

    File Added: MODSWith2subjects.jpg

     
  • Laura Akerman
    Laura Akerman
    2007-11-26

    MODS with 2 subjects

     
    Attachments
  • Laura Akerman
    Laura Akerman
    2007-11-26

    Logged In: YES
    user_id=1887270
    Originator: YES

    File Added: MODSWith2subjects.jpg

     
  • chickmarkley
    chickmarkley
    2007-12-04

    Logged In: YES
    user_id=1814905
    Originator: NO

    I've figured out what is wrong. If subject fields go into the item record discontinuously then only the last one makes it out of the JSON parsing, if they are contiguous they all come out as an array (the correct behavior). The problem was always there but exacerbated by my placing of facet information into the item record, which help with the heading analysis. I am going to have to think this one out a bit, the json encodings will have to be regenerated after the code is fixed

     
  • chickmarkley
    chickmarkley
    2007-12-04

    • labels: 986836 --> Data
    • priority: 5 --> 8
    • assigned_to: nobody --> chickmarkley
     
  • chickmarkley
    chickmarkley
    2007-12-13

    Logged In: YES
    user_id=1814905
    Originator: NO

    I believe I have fixed this, I have re-built the database on the staging server.
    Will rebuild the production server

     
  • chickmarkley
    chickmarkley
    2007-12-18

    • status: open --> pending-fixed
     
  • chickmarkley
    chickmarkley
    2007-12-18

    Logged In: YES
    user_id=1814905
    Originator: NO

    The production server has been rebuilt. I think this problem is fixed

     
1 2 > >> (Page 1 of 2)