discord 2.0.3 backward compatible, bug fix for seg fault

No changes in functionality, backward compatible.

This is a small bug fix release. I got a seg fault. When I compiled to debug there were three deprecated functions in alsa. They weren't essential to the functioning of the program. When I removed them , the seg fault cleared. I am using a beta version of the alsa lib, so they could have been the problem. On the other hand it could be a pointer error in the program that a certain configuration of inputs triggered and it is coincidence that removing them solved the problem. :-)

No other material changes, though I made a cast explicit for the stoch voice because I seemed to be getting a preponderance of pans in one direction. This could be just a fluke or a bad random number generator.

Posted by stan 2008-05-01