Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#17 Failure with Python-2.6.4 / wxpython-2.8.10.1

open
nobody
None
5
2010-02-19
2010-02-19
Helmut Jarausch
No

I get the following error messages / warnings

dirssync_gui.py:4: DeprecationWarning: The wxPython compatibility package is no longer automatically generated or actively maintained. Please switch to the wx package as soon as possible

the md5 module is deprecated; use hashlib instead
Traceback (most recent call last):
File "./run.py", line 16, in <module>
app=DsApp(0)
File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7978, in __init__
self._BootstrapApp()
File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7552, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "./run.py", line 8, in OnInit
frame=dirssync_gui.MyFrame(None,-1,"Directories Synchronizer")
File "/Work1/Src/Python/Utilities/DirsSync-2.1rc2/dirssync_gui.py", line 180, in __init__
self.__do_layout()
File "/Work1/Src/Python/Utilities/DirsSync-2.1rc2/dirssync_gui.py", line 289, in __do_layout
Sizer_InputsPanel_CMDs.Add(50, 20, 0, 0, 0)
File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 12659, in Add
return _core_.Sizer_Add(*args, **kwargs)
TypeError: wx.Window, wx.Sizer, wx.Size, or (w,h) expected for item

Is there any fix around?

Many thanks,
Helmut.

Discussion