Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

DimDim audio-video with Moodle 1.8.x?

Atia
2008-02-05
2013-05-01
  • Atia
    Atia
    2008-02-05

    Hi,
    I installed dimdim server and dimdim moodle's integration pack a few months ago with moodle 1.9 and it works fine. Unfortunatly, we need a stable version of moodle so we can not use DimDim by the moment because with 1.7 video does not work, but still looking for a videoconference aplication. I've seen in Moodle's plugins and modules that there are 3 available versions of dimdim-moodle pack to download. Actually Moodle's stable is 1.8, so I clicked on this version. It sends me to SF page but with moodle 1.9 pack. Does this mean that I can now use the integration pack 1.9 with moodle 1.8 or I still have to wait to have moodle 1.9 stable to have video in dimdim?
    Hope that you understant my problem and that you can give me an answer...
    Thanks for all,
    Atia

     
    • dimdim_dip
      dimdim_dip
      2008-02-06

      Hello Atia,

      You can set up Moodle1_9_Dimdim_ 1_6_Alpha_integration_pack with mood 1.8 stable pack.But there is a small change you have to do.
      After deploying dimdim pack inside moodle please Open "view.php" file it will be available at "\moodle\moodle\mod\dimdim" this location.
      There please change the code segment
      From
      if(dimdim_is_teacher($dimdim)) 
      To 
      if ($PAGE->user_allowed_editing()) 
      After that you can proceed with the installation.
      Please do let us know if you face any problem.

      Thank you.
      Regards,
      Dipankar