503 - Service Not Available

2008-05-30
2013-05-01
  • sandro polli
    sandro polli
    2008-05-30

    hi,
    I had a series of problems installing the version of EAGLE dimdim with VMware

    under centos wmware using ifconfig i had this : 192.168.0.2 ( the ip of the wmware )
    so the dimdim Console start on http://192.168.0.2/DimdimAdminConsole.html 
    here it's ok , all component started well and status it's ok

    if i do this , http://192.168.0.2/dimdim omitting / at the end is a mistake CherryPy due to lack of / final , and so the correct URL is this http://192.168.0.2/dimdim/

    But if i do this http://192.168.0.2/dimdim/ the error is this 503 - Service Not Available 
    Why?

    i've notice this , under CentOS WMVARE restarting httpd there is this problem 
    ------------------------------------------------------------------------------------------
    Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    ------------------------------------------------------------------------------------------

    Probably is this the error for 503 -Service Not Available ? or it's other ?
    Plese help i lost a lot of time using dimdim ...
    Regards

     
    • Hi,

      This means the Dimdim Conference server is not running. Could you please check the status of the Dimdim components. If either of the service is not running, restart the Dimdim components and confirm the status as Success and then start a meeting with http://ip/dimdim/.

      Regards,
      -Rajesh

       
    • sandro polli
      sandro polli
      2008-05-30

      i had reboot wmvare

      making this command i had this

      lsof -i :80
      COMMAND   PID   USER  FD   TYPE   DEVICE  SIZE  NODE  NAME
      lighttpd  2261  root  4u   IPv4   6638           TCP  *:http (LISTEN)

      Now http://192.168.0.2/DimdimAdminConsole.html (work well)
      so on CHECK STATUS BUTTON

      <strong>Checking Dimdim Components Status</strong>
      Checking Dimdim Conference Server Status
              Dimdim Conference server is running
      Checking Dimdim Media Server Status
              Dimdim Media Server is running
      Checking Dimdim Streaming Server Status
              Streaming server is running
      Checking Dimdim Reflector Status
              Dimdim reflector is running

      All Dimdim Components Status : Success

      but http://192.168.0.2/dimdim/ again 503 -Service Not Available.....

      i try to stop all Didmdim Components and start again controlling the Status SUCCESS , but it's seems non working ...
      503 -Service Not Available AGAIN...

      please help
      regards

       
    • Hi,

      Can you ping the ip address 192.168.0.2 from the machine where you are trying to start a meeting? Also, can you ping wwww.google.com from the vmware image where Dimdim server is running?

      Please let me know the results.

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • sandro polli
      sandro polli
      2008-05-30

      Hi,
      i try to ping 192.168.0.2 from the machine of meeting server with success ( i have a ubunt server 8.0 )
      the same thing is for the wmvare centos ping the www.google.com

      all are ok..
      regards

       
    • sandro polli
      sandro polli
      2008-06-03

      I modify port from 80 to 81 and now it works...
      i modify the port from 80 to 81 in dimdim.properties and server.xml

      but i have problems with port now ... especially the port 443

       
    • Hi sandro,

      I would request you to refer the fourm post https://sourceforge.net/forum/forum.php?thread_id=2047165&forum_id=611234 and update all the files mentioned over there regarding the port changes.

      Regarding port 443, there should be a server that might be already running.

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
      • witzter
        witzter
        2008-06-12

        I have the same error "503" and while centos vm image is booting i see

        Starting Conference Sever
        "unlinking stale socket /zdsock; sleep1
        no handlers could be found for logger "root"

        and confernce server never starts.  I have tried starting from the admin console and it looks like it starts and status says started but if i try http://my_ip/dimdim/ and get error again and then check status in admin console and Conference Server not started again.
        I have tried everything in this post with no success and even tried changing port to 81 from default 80.

        Are their any solutions to this problem or do i wait for a new vm image?

        Thanks in advance.

         
    • Hi,

      After starting the VMWare image, had you verified / configured the IP address of the machine?

      You will get 503 error, if Dimdim Conference server do not run. Could you please check the status of the Dimdim conference server using the command from a terminal

      `/usr/local/dimdim/ConferenceServer/apache-tomcat-5.5.17/bin/dimdim status`

      If the conference server is not running, run the following command from a terminal

      /usr/local/dimdim/ConferenceServer/apache-tomcat-5.5.17/bin/dimdim start

      Also, can you share your wrapper.log?

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • witzter
      witzter
      2008-06-12

      The only error in the wrapper.log is:

      INFO   |  jvm 1    | 2008/05/07 11:28:57 | INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: ../common/lib

      dimdim status returns
      DimDim Conferenceserver is running (2291)

      ifconfig returns ip of 192.168.115.113
      http://192.168.115.113/dimdim/ returns error "503"

      Does the ip configured on the vmware lan connection that was created by vmware need to match the ip returned from ifconfig?

      I can get to http://192.168.115.113/DimdimAdminConsole.html without problems??

      Thanks again.

       
    • witzter
      witzter
      2008-06-12

      SUCCESS !!
      WOW  after alot of time spent on this i have figured it out and thought i would pass on what the simple solution to the problem was.

      When starting VMPLAYER and choosing your VM you must choose the option "i moved it" when asked weather you moved or copied the VM.  After that the default VM image ran without flawless without changes.

      Thanks

       
    • Hi

      Yes. This needs to be done. Thanks for the updates. We will update this in the readme for the next release.

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • Julian Muller
      Julian Muller
      2008-07-31

      YEAH! for example:
      If you bind eth0 as BRIDGED and then Move the VMWAre Image (or copy) to other VMware Works or Player (and dont choose) "I've moved", Somenthing can happen: for example: your eth0 config changes (mac address is different)

       
    • John
      John
      2008-08-07

      I am having a similiar problem. I followed the instructions on changing ports to 81. I have FC7, RH linux. Able to access Admin panel with port set to 81 in lighttpd, server.xml, dimdim.properties, and dimdim.streaming, but get 503 error when I do http://<server>:81/dimdim/.

      wrapper.log
      INFO   | jvm 1    | 2008/08/07 00:45:31 | Aug 6, 2008 10:45:31 PM org.apache.catalina.startup.Catalina start
      INFO   | jvm 1    | 2008/08/07 00:45:31 | SEVERE: Catalina.start:
      INFO   | jvm 1    | 2008/08/07 00:45:31 | LifecycleException:  service.getName(): "Catalina";  Protocol handler start failed: java.net.BindException: Address already in use:81
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.apache.catalina.connector.Connector.start(Connector.java:1096)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.apache.catalina.core.StandardService.start(StandardService.java:459)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.apache.catalina.core.StandardServer.start(StandardServer.java:709)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at java.lang.reflect.Method.invoke(Method.java:597)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:294)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:432)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at java.lang.reflect.Method.invoke(Method.java:597)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at org.tanukisoftware.wrapper.WrapperStartStopApp.run(WrapperStartStopApp.java:302)
      INFO   | jvm 1    | 2008/08/07 00:45:31 |       at java.lang.Thread.run(Thread.java:619)
      INFO   | jvm 1    | 2008/08/07 00:45:31 | Aug 6, 2008 10:45:31 PM org.apache.catalina.startup.Catalina start
      INFO   | jvm 1    | 2008/08/07 00:45:31 | INFO: Server startup in 8547 ms

       
    • John
      John
      2008-08-07

      if i leave server.xml at 8080 as it says and change all else to 8000 I get a tomcat/5.5.1 error page.