StreamingServer crashes

markw78
2007-12-14
2013-05-01
  • markw78
    markw78
    2007-12-14

    if I share a desktop or any application then stop it and share it again, this error occurs and the dssServer crashes every time, very reproducible and unusable.  Once I finally gave up on installing on Gentoo (Alpha 1.6 we ran on Gentoo) and giving up on CentOS 5 we finally downloaded the 4.5 and the install script worked without issue.   If I can get this issue below and port 80 working I can start letting users test again.

    The GUI just says "Image Processing failure - Please try again"  Of course at this point dssServer is no longer running so it never recovers.  I can restart with run_dimdim_server script but it will just crash again.   Just now the service crashed with nothing in the log.  All of a sudden I was changing shared apps and the connection would not establish, netstat on the server showed the services no longer listening, again.  This is the first time I've seen something logged when the issue occured.

    3608184146 - <info> - [dSS] - Registering subscriber... 08d88b12-aa03-11dc-8000-000000000000
    3608184146 - <info> - [dSS] - Sending key frame #[0 / 6] to ... Subscriber [08d88b12-aa03-11dc-8000-000000000000]
    3608184146 - <info> - [dSS] - Sending key frame #[1 / 6] to ... Subscriber [08d88b12-aa03-11dc-8000-000000000000]
    3608184153 - <info> - [dSS] - Sending key frame #[2 / 6] to ... Subscriber [08d88b12-aa03-11dc-8000-000000000000]
    3608184157 - <info> - [dSS] - Sending key frame #[3 / 6] to ... Subscriber [08d88b12-aa03-11dc-8000-000000000000]
    3608184164 - <info> - [dSS] - Sending key frame #[4 / 6] to ... Subscriber [08d88b12-aa03-11dc-8000-000000000000]
    3608184170 - <info> - [dSS] - Sending key frame #[5 / 6] to ... Subscriber [08d88b12-aa03-11dc-8000-000000000000]
    3608184172 - <info> - [dSS] - XXXX Play Successful : Stream (98c0853dd51a7199eea7a39b.1.D)
    3608184174 - <info> - [dSS] - SimplePacketHandler::onInvokePacket(play) - ENDS
    3608184175 - <info> - [dSS] - SimplePacketHandler::onInvokePacket(receiveVideo) - BEGINS
    3608184176 - <info> - [dSS] - SimplePacketHandler::onInvokePacket(receiveVideo) - ENDS
    3608231247 - <warning> - [dSS] - Failed to parse pending pdu data of length : 1017 bytes!E¤ú^Bt^Eéå

    PS - 2 hours later -

    I followed the Linux_Readme_1.5.0.txt file in the ConferenceServer folder and changed my install to run Java 1.5.  JAVA_HOME was not set and I was pointed to use one in 3rdpartytools/jre1.6 but I changed it to use /usr/java/jre1.5 instead.  I also added a 2nd Streaming server I think on 30002.   The server in general seemed a lot better now, but still after much clicking and fast changing of screens.  I was clicking links to images in a browser window I was sharing and the client just suddenly got kicked off for no reason.  No logs or anything, ports 40001 1935 are both gone again.  I run one of the install scripts and it's fine again for awhile. 

    Thanks in advance for any advice!

     
    • Hi,

      Could you please let me know where you are installing and running dimdim - in a VMWare setup or a normal desktop machine?

      Regards,
      -Rajesh

       
    • markw78
      markw78
      2007-12-14

      Hi Rajesh.  It is a Vmware server.  Have you seen this before?  Do you have any suggestions?

       
    • Adrian Lewis
      Adrian Lewis
      2008-01-04

      I too have this issue. Server is a Centos 4.5 Vmware Server guest machine. Vmware server itself is running 1.0.4 on Centos 5.0. Yum updated all the way. I haven't checked the JRE settings as described above but I can at least say that it is reproducable.

       
    • Sigurd Hansen
      Sigurd Hansen
      2008-03-07

      We have the same problem as well. Did a clean install of Centos 4.5 and did a yum update(which changed the version to 4.6) I actualy had to fake version 4.5 to get the installer working. Anyway, everything works fine, exept that dss dies all the time.