Upload PPT with conversion failed dimdim v.35

skyvenz
2008-05-28
2013-05-01
  • skyvenz
    skyvenz
    2008-05-28

    Hi all,

    Please kindly help me, i upload powerpoint file with generate this error msg:

    The document conversion failed with error: Invalid content (can be either zero byte file, corrupt file or unsupported file type may be pptx)..

    This not happen in PDF file.

    My Dimdim Platform: CentOS 5.1
    Dimdim version 3.5 OpenSource

    i've check /usr/local/dimdim/Mediaserver/www/logs/cherrypy_error.log

    here the log result:

    [28/May/2008:11:18:51]  DMS build 041708 - Job created... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  Validating Content... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  Checking if 0 byte... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  /usr/local/dimdim/Mediaserver/www/media/dmfb7997.ppt
    [28/May/2008:11:18:51]  0 byte check passed... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  Max filesize check... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  Max filesize check passed... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  :::CONVERSION STATE getting set to office for docID = dmfb7997
    [28/May/2008:11:18:51]  Acquired office semaphore for meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  Conversion could have been cancelled... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:51]  :::CONVERSION STATE getting set to done for docID = dmfb7997
    [28/May/2008:11:18:51]  Job completed... meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:52]  releasing office for meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:52]  Released office semaphore for meeting ID = 12345 and docID = dmfb7997
    [28/May/2008:11:18:52]  :::HARAKIRI::: cleanup done for meeting ID = 12345 and docID = dmfb7997

    And please let me know where i can find the dms.log ?? i locate the /usr/local/dimdim/logs is not exist.

    Thank you in advance.

    Regards,
    skyvenz

     
    • skyvenz
      skyvenz
      2008-05-28

      My PPT file only 81Kb

       
      • Hello,

        I have same troubles,
        My config :
        Unbuntu Hardy, everything work fine except the PPT upload.
        1 ) root@dimdim...al/dimdim/Mediaserver/mods >ls -al /usr/bin/soffice.bin
        lrwxrwxrwx 1 root root 39 2008-06-03 12:03 /usr/bin/soffice.bin -> /usr/lib/openoffice/program/soffice.bin
        2 ) root@dimdim...al/dimdim/Mediaserver/mods >netstat -an | grep 8100 #give me nothing
        3 ) root@dimdim...al/dimdim/Mediaserver/mods >ps -aef | grep soffice.bin  #give me nothing

        To beginning, I have this message if I tried to start soffice manually :

        root@dimdim...al/dimdim/Mediaserver/mods >./StartOO.sh
        /usr/lib/openoffice/program/soffice.bin X11 error: Can't open display:
           Set DISPLAY environment variable, use -display option
           or check permissions of your X-Server
           (See "man X" resp. "man xhost" for details)

        After I trie to give it a X server :
        root@dimdim...al/dimdim/Mediaserver/mods >Xvfb :10000 -screen 0 800x600x24 &

        It's working better but I have in the cherrypy_error.log :

        [03/Jun/2008:16:33:33]  killing All openoffice process---
        [03/Jun/2008:16:33:33]  waiting to start openoffice---
        [03/Jun/2008:16:33:33]  starting oo process
        [03/Jun/2008:16:33:41]  Error in resolving url resolver---
        [03/Jun/2008:16:33:41]  openoffice couldnot get start even after waiting for it---
        [03/Jun/2008:16:33:41]

        [03/Jun/2008:16:33:41]  DMS build 041708 - Job created... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  Validating Content... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  Checking if 0 byte... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  /usr/local/dimdim/Mediaserver/www/media/qbis1306.ppt
        [03/Jun/2008:16:33:41]  0 byte check passed... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  Max filesize check... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  Max filesize check passed... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  :::CONVERSION STATE getting set to office for docID = qbis1306
        [03/Jun/2008:16:33:41]  Acquired office semaphore for meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  Conversion could have been cancelled... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:41]  :::CONVERSION STATE getting set to done for docID = qbis1306
        [03/Jun/2008:16:33:41]  Job completed... meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:42]  releasing office for meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:42]  Released office semaphore for meeting ID = toto and docID = qbis1306
        [03/Jun/2008:16:33:42]  :::HARAKIRI::: cleanup done for meeting ID = toto and docID = qbis1306

        Is there something wrong in my config ? Or did I miss something ?

        Thks for helping.

        Regards,

        --
        Geoffroy RENAUD
        Nomadvantage

         
    • Hi,

      The problem could be soffice is not started properly. Could you please let me know the following:

      1. ls -al /usr/bin/soffice.bin
      2. netstat -an | grep 8100
      3. ps -aef | grep soffice.bin

      Also, had you modified osconfig.py for open office path as mentioned in readme?

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • Sigurd Hansen
      Sigurd Hansen
      2008-05-28

      I have the same problem on my server. 1: /usr/bin/soffice.bin exist, 2: port not in use,3: no soffice.bin process found, 4: osconfig.py is modified.

      -Sigurd

       
    • Hi,

      Can you please let me know the link of the soffice.bin? Also provide me the path of open office from osconfig.py

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • Sigurd Hansen
      Sigurd Hansen
      2008-05-28

      [root@dimdim ~]# ls -la /usr/bin/soffice.bin
      lrwxrwxrwx  1 root root 42 mai 22 12:21 /usr/bin/soffice.bin -> /opt/openoffice.org2.4/program/soffice.bin

      [root@dimdim toolkit]# cat osconfig.py |grep office
          return os.path.dirname('/opt/openoffice.org2.4/program/')

      -Sigurd

       
    • skyvenz
      skyvenz
      2008-05-29

      My problems has been resolved thank to : Rajesh

      Causes of false link /usr/bin/soffice -> /opt/openoffice.org2.4/program/soffice.bin

      Resolution:
      1. delete old link /usr/bin/soffice
      2. recreate new link /usr/bin/soffice -> /opt/openoffice.org2.4/program/soffice.bin

      thank you.

       
    • Hi,

      I guess this issue could be because of permission issue. Could you please try to run in sudo mode and see if you see the same problem while trying to start StartOO.sh?

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • I don't run in sudo mode, I run it in su mode like my prompt confirm :
      root@dimdim...al/dimdim/Mediaserver/mods >./StartOO.sh

      Every programs of dimdim installation run in root so this is not a problem of permission.

      Regards,

      --
      Geoffroy RENAUD
      Nomadvantage

       
    • spark
      spark
      2008-06-29

      Hi, i was also struggling over the same problem, and my solution was:

      1. reinstalled openoffice
      2. checked if there is a symbolic link pointing to it
      3. checked whether osconfig.py has the correct value for openoffice installation path
      4. StartOO.sh was trying to start soffice.bin, whilst i had a link to soffice, so i changed it to start soffice. In fact i think a direct link to /opt/openoffice2.4/program/soffice.bin can be provided

       
    • Hi Geoffroy RENAUD,

      I hope your problem got solved, if not please drop a mail to rajesh@dimdim.com with the issue you are facing.

      Regards,
      -Rajesh
      rajesh@dimdim.com