Dimmdimm server behid of firewall

deepjavero
2008-02-22
2013-05-01
  • deepjavero
    deepjavero
    2008-02-22

    I like to install a dimm server over windows 2000 profesional for testing and behind of firewall. I just like to work in intranet for testing the server, when I install the server, send me the message

    " Either of ports( 80, 1935, 40000 and 40001) are already occupied. Please stop servers are listening these ports and then continue installtion"

    How cal I fix this problem for  dimmdimm server works with out to internet ?

    Best regards

     
    • dimdim_dip
      dimdim_dip
      2008-02-23

      Hi,

      Thanks for your interest in Dimdim.
      There are three main components in Dimdim.
      DCS: Dimdim Conference server.
      DMS: Dimdim Media server. Responsible for sharing presentation. 
      DSS: Dimdim streaming server.Responsible for live streaming data.
       
      These servers runs on port 40000,80,40001 and on port 80.So these ports needs to be free.Kill the processes which are running on these ports and try to install Dimdim again.

      Please do let us know if this solves your problem.

      Regards,
      Dipankar

       
    • deepjavero
      deepjavero
      2008-02-23

      Thanks

      I have to uninstall some software, that block the ports used by dimdim server. I installed the product, but now when launch startdimdim.bat all see good but when up the browser URL http://myip/dimidim/, the server not response,  or send me the message  The "connection has timed out". I saw the tomcat server it is not working (and  the process  too).

      These are happening with windows XP and windows 2000

      Do you know  what is wrong?

      Best  regards

       
    • I have exactly the same issue on XP pro. I ran port explorer and nothing was using these ports yet it still gave this error. This is a crumby program and wasted 3 hours of my Saturday afternoon. I am now using PCHelpWare which actually works how it is supposed to and installs without these tiresome issues! Thanks for nothing.

       
    • deepjavero
      deepjavero
      2008-02-25

      Great:

      I done something bizar, download the tomcat 5.5.26 copy the folders conf and bin( only tomcat bootstrap,commons-logging-api-1.1.1, tomcat5,tomcat5w and tomcat-juli files of bin) and overwrite the next folders of tomcat in the dimdim:

      config (by conf of new version of tomcat folder)
      bin

      Reset al services and see the server.xml, and  it must appear the httpport 8080 by default( before this word not appear "Connector port="8080").

        <!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->
          <Connector port="8080"               maxHttpHeaderSize="8192"
                     maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
                     enableLookups="false" redirectPort="8443" acceptCount="100"
                     connectionTimeout="20000" disableUploadTimeout="true" />
          <!-- Note : To disable connection timeouts, set connectionTimeout value
           to 0 -->

      Lauch your application again and the http://myip/dimdim/ must show.

      I think that dimdim server has problems with tomcat server that it´s integrate with the opensource version.

      No I have to resolve the problem the next message when I create a meeting
      "Exceeded server limit of meetings."

      Best Regards

       
    • Heinkki Tanaka
      Heinkki Tanaka
      2008-03-05

      Hi all.

      I'd download the DIMDIM 3.0.0_Beta(05012008.
      I'd download Open Office OOo_2.3.1_Win32Intel_install_wJRE_en-US.exe.

      Install Open Office.
      Install dimdim.exe. (with 192.168.0.2)

      The public static IP is in Linux Fedora6 machine. (Internet 200.x.x.x and LAN 192.168.0.1).
      My DIMDIM server is a Windows XP SP2 (without firewall or any block), in LAN (192.168.0.2).

      All machines at LAN access the DIMDIM ok! Perfect!

      I need to access DIMDIM from internet.
      I'd configure rules in my Linux Firewall to redirect the ports:
      iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 80 -j DNAT --to-destination 192.168.0.2
      iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 1935 -j DNAT --to-destination 192.168.0.2
      iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 40000 -j DNAT --to-destination 192.168.0.2
      iptables -t nat -A PREROUTING -p TCP -s 0/0 --dport 40001 -j DNAT --to-destination 192.168.0.2

      BUT... Doesn't work.

      In external machine, I type http://externalIP/ and return this:
      -------------------------------------------------------
      404 Not Found
      The path '/' was not found.

      Traceback (most recent call last):
        File "C:\Program Files\OpenOffice.org 2.3\program\python-core-2.3.4\lib\site-packages\cherrypy\_cprequest.py", line 551, in respond
          cherrypy.response.body = self.handler()
        File "C:\Program Files\OpenOffice.org 2.3\program\python-core-2.3.4\lib\site-packages\cherrypy\_cperror.py", line 198, in __call__
          raise self
      NotFound: (404, "The path '/' was not found.")
      Powered by CherryPy 3.0.1
      -------------------------------------------------------

      But http://externalIP/dimdim/ don't return anything. Blank page!
      I tried with IE7 and FF, always on external machine.

      I'd see https://sourceforge.net/forum/message.php?msg_id=4762613
      But doesn't work again.

      C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\webapps\dimdim\WEB-INF\classes\resources\streaming.properties
      - streaming_server.1.rtmp_url=rtmp://200.x.x.x/
      - streaming_server.1.rtmpt_url=rtmpt://200.x.x.x:40001/

      C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\webapps\dimdim\WEB-INF\classes\resources\dimdim.properties
      - dimdim.serverAddress=200.x.x.x
      - dimdim.serverPortNumber=80
      - dimdim.dmsServerAddress=200.x.x.x:80

      C:\lighttpd\etc\lighttpd.conf
      server.port = 80
      server.bind = "192.168.0.2"

      -------------------------------------------------------

      Resuming: for machines on LAN dimdim work perfect! Machines on internet, doesn't work.
      The nat rules in Linux box are active.

      Any help?
      Thanks!

      Heinkki.

       
    • Hi Heinkki,

      You need to open ports 80, 1935 and 400001. With these 3 ports open, Dimdim can be accessed across firewall.
      Could you please let me know the following:
      1.    Were you able to access the Start or join page? This can be confirmed by http://<external ip address>:80/dimdim/
      2.    Were you able to go to the main console page, where you will see the options to share desktop / audio-video?
      If not both, could you please explain me briefly where you are stuck at?

      After opening the ports, you can try telnet to the following from the presenter's machine:
             Open a command prompt and do
                        telnet <external ip address> 80
                        telnet <external ip address> 1935 
                        telnet <external ip address> 40001
      If you get a connection timed out, Dimdim server is  not running. If you get Connection refused, the firewall blocked access to that ports.

      Regards,
      -Rajesh
      rajesh@dimdim.com

       
    • Intruder
      Intruder
      2008-06-13

      Hi

      Teh problem is with the windows firewall, I disable and dimdim works fine no teh problem is with audio, when I add more active mics, the audio broadcaster stopped

      Some reporte about this issue ?

       
    • Mauricio Mora
      Mauricio Mora
      2008-06-19

      Hi Heinkki,

      I had exactly the same problem, apparently many people have the same issue with the beta version 3 running in windows, my system is a windows xp pro sp2:

      here my solution:

      1. download and install open office 2.3.1, use the default settings

      2. download and install dimdim 3.0 beta for windows, use the default settings

      3. set your dimdim server with a static IP address and disable the windows firewall in the interface properties.

      4. configure port forwarding in your firewall (depends on the firewall vendor the name will change, some other names i I have seen are: port mapping, static PAT, NAT etc.) just make sure external requests in TCP ports 80, 1935 and 40001 are being send to your dimdim server

      5. go to C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\webapps\dimdim\WEB-INF\classes\resources

      edit the file "streaming.properties", change the ip addresses of the following lines with your public IP address:
      streaming_server.1.rtmp_url=rtmp://x.x.x.x/
      streaming_server.1.rtmpt_url=rtmpt://x.x.x.x:40001/

      edit the file "dimdim.properties" to use your public ip address:

      dimdim.serverAddress=x.x.x.x
      dimdim.serverPortNumber=80
      dimdim.dmsServerAddress=x.x.x.x:80

      6. go to C:\Program Files\Dimdim\MeetingServer\Conference Server\Tomcat 5.5\conf and edit the file "server.xls" , find the following line:

      <Host appBase="webapps" unpackWARs="true" autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false" name="x.x.x.x">

      replace the ip address of the "name=" space with your public ip address

      7. (optional) go to C:\lighttpd\etc, edit the file "lighttpd.conf", find the following line:
      #server.bind                = "grisu.home.kneschke.de"

      and replace it:

      server.bind                = "y.y.y.y"

      where y.y.y.y is the server private ip address

      8. Reboot the server

      Side Effect: Dimdim will only work from the internet and not in your LAN anymore.