Email notification broken

Help
2007-04-27
2013-05-01
  • Hello all.

    My dimdim installation on a CentOS 4.4 box with jdk-1.5.0_08 was working until today.  I had turned it off for several days, then fired it up today.  I can create a meeting, but no email notifications go out, whether add at the time of meeting creation, or after the meeting has started.  Here's the output of wrapper.log (hope I've included enough:

    INFO   | jvm 1    | 2007/04/27 17:48:41 | In GetConsolePageAction : Returning -success
    INFO   | jvm 1    | 2007/04/27 17:48:41 | Loading Console - Time:1177710521862
    INFO   | jvm 1    | 2007/04/27 17:48:41 | TAG Locale Language:en
    INFO   | jvm 1    | 2007/04/27 17:48:41 | ************************ Setting up the user info in console for http session:7209EFD4A64CCEB8970ED11F839D19D1
    INFO   | jvm 1    | 2007/04/27 17:48:41 | * ********** Opening console in Firefox
    INFO   | jvm 1    | 2007/04/27 17:48:41 | Console loading complete - Time:1177710521878
    INFO   | jvm 1    | 2007/04/27 17:48:42 | Loading Console Data - Time:1177710522388
    INFO   | jvm 1    | 2007/04/27 17:48:42 | ***** Initial event poll time from resource file:1000
    INFO   | jvm 1    | 2007/04/27 17:48:42 | ***** Regular event poll time from resource file:100
    INFO   | jvm 1    | 2007/04/27 17:48:42 | ***** Max event failures from resource file:300
    INFO   | jvm 1    | 2007/04/27 17:48:42 | Session Key:S11235046ba8zppofmdmykr
    INFO   | jvm 1    | 2007/04/27 17:48:42 |       audio_rtmp_url=rtmp://www.mydomain.com/dimdimPublisher
    INFO   | jvm 1    | 2007/04/27 17:48:42 |       audio_rtmpt_url=null
    INFO   | jvm 1    | 2007/04/27 17:48:42 | Console data loading complete - Time:1177710522412
    INFO   | jvm 1    | 2007/04/27 17:48:43 | Current State: 1
    INFO   | jvm 1    | 2007/04/27 17:48:43 | Checking admin@dimdim.com, current state:1, against new state: 4
    INFO   | jvm 1    | 2007/04/27 17:50:48 | *******************************
    INFO   | jvm 1    | 2007/04/27 17:50:48 | Attendees:dyioulos@firstbhph.com
    INFO   | jvm 1    | 2007/04/27 17:50:48 | Presenters:
    INFO   | jvm 1    | 2007/04/27 17:50:48 | Message:
    INFO   | jvm 1    | 2007/04/27 17:50:48 | *******************************
    INFO   | jvm 1    | 2007/04/27 17:50:48 | Email Invitation: From Template
    INFO   | jvm 1    | 2007/04/27 17:50:48 | emailServer:mail1.mydomain.com
    INFO   | jvm 1    | 2007/04/27 17:50:48 | emailUser:root
    INFO   | jvm 1    | 2007/04/27 17:50:48 | emailPassword:blahblah
    INFO   | jvm 1    | 2007/04/27 17:50:48 | emailSender:root@mydomain.com
    INFO   | jvm 1    | 2007/04/27 17:50:48 | Email dispatch worker 2 - sending out email:Admin
    INFO   | jvm 1    | 2007/04/27 17:50:49 | javax.mail.AuthenticationFailedException
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at javax.mail.Service.connect(Service.java:267)
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at javax.mail.Service.connect(Service.java:137)
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at com.dimdim.conference.application.email.Mailer2.sendMessage(Mailer2.java:332)
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at com.dimdim.conference.application.email.EmailDispatchWorker2.sendEmail(EmailDispatchWorker2.java:174)
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at com.dimdim.conference.application.email.EmailDispatchWorker2.sendEmail(EmailDispatchWorker2.java:127)
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at com.dimdim.conference.application.email.EmailDispatchWorker2.run(EmailDispatchWorker2.java:94)
    INFO   | jvm 1    | 2007/04/27 17:50:49 |       at java.lang.Thread.run(Thread.java:595)

    What happened here?

    Thanks.

    alfred_e_neuman

     
    • dimdim_uday
      dimdim_uday
      2007-04-28

      Hello,
      Did you modify the dimdim.properties to change the email Smtp credentials?
      There is a authentication failure message in the log you have posted.

      INFO   | jvm 1    | 2007/04/27 17:50:49 |
      javax.mail.AuthenticationFailedException

      Uday

       
      • John
        John
        2007-12-16

        I am having the same problem. I know my settings are right they work in Outlook. I get Email Dispatch Failure in the Pending Tasks box.

        here is the tail of wrapper.log just after the error

        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at javax.mail.internet.MimeMessage.getAddressHeader(MimeMessage.java:661)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at javax.mail.internet.MimeMessage.getFrom(MimeMessage.java:321)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java:844)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:535)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at com.dimdim.conference.application.email.Mailer2.sendMessage(Mailer2.java:379)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at com.dimdim.conference.application.email.EmailDispatchWorker2.sendEmail(EmailDispatchWorker2.java:211)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at com.dimdim.conference.application.email.EmailDispatchWorker2.sendEmail(EmailDispatchWorker2.java:153)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at com.dimdim.conference.application.email.EmailDispatchWorker2.run(EmailDispatchWorker2.java:115)
        INFO   | jvm 1    | 2007/12/15 20:52:00 |       at java.lang.Thread.run(Unknown Source)
        INFO   | jvm 1    | 2007/12/15 20:52:00 | QUIT

        any ideas??

         
    • I don't believe I've changed a thing.  All I did was shut down the dimdim server for a few days.  Then, when I restarted it, the problems began.

      Yes, I see the authentication failure message.  Here's my set-up:

      dimdim server:  www.mydomain.com:8080
      mail server:  mail1.mydomain.com
      email user:  myname
      email password:  mypassword
      email sender:  myname@mydomain.com
      email port:  25

      So, my mail server is on a separate box.  The dimdim server is set up to relay mail to the email server.  If I send an email message to me from the dimdim server (not from within dimdim), it's delivered, with a sender address of root@www.domain.com (as I've su'd to root).  I, of course, have an email account, so any mail sent by me ot to me has an address of myname@mydomain.com.  If, however, I log into the dimdim server box and send email, it's addressed from myname@www.mydomain.com, as I have an account on this machine.

      So, how do I need to set-up the mail piece in dimdim to make this work again?

      Thanks.

      alfred_e_neuman

       
    • Hi alfred,

      Thanks for the updates. With the Dimdim rpm package, there is a default SMPT server settings which will be configured as a post install. Could you please try with that and let us know if that works?

      Or You can give the following in the dimdim.properties of existing install and let us know:
      email.server=smtp.atlarge.net
      email.user=invitation.communiva
      email.password=summer2006
      email.sender=invitations@dimdim.com
      email.PORT=25

      email.EMAIL_FROM_PERSON=DimDim Invitations
      email.EMAIL_FROM=invitations@dimdim.com
      email.EMAIL_REPLY_TO=invitations@dimdim.com

      Regards,
      -Rajesh

       
    • The default doesn't work, either.  I've tried every combination of email-related setting in dimdim.properties that I can think of, and I simply can't get it to work.  Yet, I seem to have had it working early last week.  I have made no changes to my dimdim server in the interim.  And, I can mail to anyone directly from that server.

      Any other ideas?

      alfred_e_neuman

       
    • Alfred,

      Will it be possible for you to provide access to your machine? if so could you please mail me at rajesh(@)dimdim.com the credentials? Also, please do send me the new wrapper.log with the default smtp server settings which i have provided?

      Regards,
      -Rajesh

       
    • Rajeesh,

      This is a known issue which is being worked on by the developers, right?

      alfred_e_neuman

       
    • Hi Alfred,

      Yes there is an issue and we are working on that.

      Regards,
      -Rajesh

       
    • dimdim developers,

      Any progress on this issue?  Just looking for a ststus update.

      alfred_e_neuman

       
    • seanbrandon
      seanbrandon
      2007-06-06

      I am getting this same error when I leave out authentication all together.  When I put in a correct username and password, it works fine.  Our smtp server does not require authentication.  Is there anyway you can put in an argument that turns off auth login? 

       
    • Hello Alfred and seanbrandon ,

      Yes. This issue is not addressed yet. This release had only windows version. We will update you more on this.

      Regards,
      -Rajesh

       
    • Joshua Bedgood
      Joshua Bedgood
      2007-09-20

      Any update on using SMTP without authentication? My SMTP server does not use authentication so currently I can not send email notifications from DimDim.

      Thanks,
      Josh

       
    • Andre Lomonaco
      Andre Lomonaco
      2007-10-03

      Hi,

        I did some tests using TCPDUMP. Here are the results and maybye a resolution:

        NOT WORKS

        When DimDim send an e-mail to a Server which responds with AUTH, Dimdim always will try
        to authenticate. The Server will sent back the 503 message if he already authenticate
        the host (by IP Address, for example)

       
        220 k2smtpout02-01.prod.mesa1.secureserver.net ESMTP
        EHLO ip-208-109-163-197.ip.secureserver.net
        250-k2smtpout02-01.prod.mesa1.secureserver.net
        250-AUTH LOGIN PLAIN
        250-8BITMIME
        250 PIPELINING
        AUTH LOGIN
        503 You are already authenticated.

        WORKS

        1) When DimDim send an e-mail to a Server which responds with AUTH and requires
        authentication.

        2) When DimDim send an e-mail to a Server which not responds with AUTH.

        220 hydrogen Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at  Wed, 3 Oct 2007 13:00:51 -0300
        EHLO telipplus001.ipplus.com.br
        250-hydrogen Hello [192.168.254.5]
        250-TURN
        250-SIZE 2097152
        250-ETRN
        250-PIPELINING
        250-DSN
        250-ENHANCEDSTATUSCODES
        250-8bitmime
        250-BINARYMIME
        250-CHUNKING
        250-VRFY
        250 OK
        MAIL FROM:<lomonaco@ipplus.com.br>
        250 2.1.0 lomonaco@ipplus.com.br....Sender OK

        POSSIBLE SOLUTION

          I take a look in the Mailer2.java file and I suggest the following change:

          ORIGINAL

          // Create the session's properties
          Properties props = new Properties();
          props.put("mail." + protocol + ".auth", "true");

          CHANGE

          // Create the session's properties
          Properties props = new Properties();
          if (user!=null) { props.put("mail." + protocol + ".auth", "true"); }

          OR

          // Create the session's properties
          Properties props = new Properties();
          if (SOME_FLAG_AUTH_SMTP==true) { props.put("mail." + protocol + ".auth", "true"); }

          I ask someone if possible to test this change. If works, please send me the
          Mailer2.class, cause I can't compile here. I'm using Linux (Centos 4) and my ant
          doesn't works.
       
          My skype is andrelomonaco.

          My Best Regards,

          Andre Lomonaco
            

       
      • Tim Clarke
        Tim Clarke
        2007-11-02

        Does anyone have a fixed Mailer2.class file to get over this authentication issue, please?