mail won't send

Help
rpmayhem
2009-04-28
2013-05-01
  • rpmayhem
    rpmayhem
    2009-04-28

    I'm trying to setup the prebuilt VM 4.5 dimdim server.  Everything is running great except for the mail function.  Our mail server is Exchange 2007 SP1.  The exchange server is setup to allow anonymous e-mail from the dimdim server (no auth need).  I've used the same exchange setup many times for many different apps.

    However, the logs show that the dimdim server is trying to authenticate to the mail server and is failing.  It successfully sends the helo command, but it's the AUTH LOGIN part that fails.  It shouldn't even need to authenticate at all, but I don't see a way to turn that off.

    I've also tried to put in a valid username and password in dimdim.properties, but that didn't fix the problem.  I've been using the StartDimdim.sh script to make sure the changes get applied, but still no go.

    Here's my config (with sensitive items changed/removed)...

    ##      Email Parameters that can be configured by the user.
    ##
    email.server=x.x.x.x
    email.user=
    email.password=
    email.sender=meeting@domain.com
    email.PORT=25
    email.EMAIL_CC=
    email.EMAIL_BCC=
    ##
    ##
    email.PROTOCOL=smtp
    email.DEBUG_MAIL_SESSION=true
    email.BUFFER_SIZE=2048
    email.EMAIL_SUBJECT = has invited you to a web meeting.
    email.EMAIL_FROM_PERSON=Meeting Invitations
    email.EMAIL_FROM=meeting@domain.com
    email.EMAIL_REPLY_TO=meeting@domain.com
    email.EMAIL_TO=
    email.EMAIL_CHARSET=utf-8
    ##
    ##
    ##  This property refers to type of the SMTP Server
    ##  1 : Non SSL SMTP Server i.e. Dimdim SMTP Server
    ##  2 : SSL SMTP Server  i.e. gmail SMTP Server
    dimdim.smtptype=1

    Any help is appreciated.  Thanks.

     
    • rpmayhem
      rpmayhem
      2009-04-28

      I found the following line in my logs:

      INFO   | jvm 1    | 2009/04/28 15:35:02 | DEBUG SMTP: useEhlo true, useAuth true

      Does anyone know how to set useAuth to false?

       
    • rpmayhem
      rpmayhem
      2009-04-28

      Ok, I figured it out.  I found this post (https://sourceforge.net/forum/message.php?msg_id=4550617) from way back and learned that dimdim actually looks at your mail server's ehlo response to see if it needs to authenticate.  The receive connector on my exchange mail server is set to allow the server to try to authenticate, but it's not necessary.

      So, I created a new receive connector with all auth options disabled and it worked!  By refusing any mail auth on the connector, dimdim stopped trying to connect.