Change LAN IP

Joe
2009-04-01
2013-05-01
  • Joe
    Joe
    2009-04-01

    I set up DimDim without any issues at all.  I ste up the router for NAT and then Config-ipaddress.pl and mapped my URL to my Vmware IP 198.162.1.110.

    This worked great!

    Last week my router failed.  It is a Linksys Router on Cable.  Same as I had before.  Now my Vmware ID is 198.162.1.103.  This is the address when I run ifconfig eth0 and its the address that shows up in teh router DHCP table.  I've forarded all teh same ports as before. I've run the Config-ipaddress.pl as I did before but I can not get it to work.

    Any ideas on how to fix?

     
    • Joe
      Joe
      2009-04-01

      Further review indicates that the router will not allow forwarding to a DHCP address.  So I need to assign a static ip address and I need some help: From the Install Doc: 

             
      STEP1
      vi /etc/sysconfig/network-scripts/ifcfg-eth0
             
         
               DEVICE=eth0
               BOOTPROTO=static
               BROADCAST=XXX.XXX.XXX.255
               IPADDR=XXX.XXX.XXX.XXX
               NETMASK=255.255.255.0
               NETWORK=XXX.XXX.XXX.0
               ONBOOT=yes

      What should NETWORK be?  Is this my Router LAN IP 192.168.1.1  or is this my WAN IP 71.25.xxx.xxx?

      STEP3
      vi /etc/sysconfig/network
              NETWORKING=yes
              NETWORKING_IPV6=yes
              HOSTNAME=localhost.localdomain
              GATEWAY=XXX.XXX.XXX.1

      Whate should GATEWAY BE? Is this the "Default Gateway" as shown on the router status screen:  71.59.xxx.xxx or my Router Internet IP?

       
      • Mike
        Mike
        2009-04-01

        >What should NETWORK be? Is this my Router LAN IP 192.168.1.1 or is this my WAN IP 71.25.xxx.xxx?

        192.168.1.0 since your IP is in the 192.168.1.x subnet and the netmask is 255.255.255.0

        >Whate should GATEWAY BE?
        this is internal IP of your firewall/router, 192.168.1.1

        DEVICE=eth0 
        BOOTPROTO=static 
        BROADCAST=192.168.1.255
        IPADDR=192.168.1.50 (or whatever you choose)
        NETMASK=255.255.255.0 
        NETWORK=192.168.1.0 
        ONBOOT=yes

        NETWORKING=yes
        NETWORKING_IPV6=no
        HOSTNAME=dimdim.localdomain
        GATEWAY=192.168.1.1

         
    • Joe
      Joe
      2009-04-02

      Further review indicates that the router will not allow forwarding to a DHCP address.  So I need to assign a static ip address and I need some help: From the Install Doc: 

             
      STEP1
      vi /etc/sysconfig/network-scripts/ifcfg-eth0
             
         
               DEVICE=eth0
               BOOTPROTO=static
               BROADCAST=XXX.XXX.XXX.255
               IPADDR=XXX.XXX.XXX.XXX
               NETMASK=255.255.255.0
               NETWORK=XXX.XXX.XXX.0
               ONBOOT=yes

      What should NETWORK be?  Is this my Router LAN IP 192.168.1.1  or is this my WAN IP 71.25.xxx.xxx?

      STEP3
      vi /etc/sysconfig/network
              NETWORKING=yes
              NETWORKING_IPV6=yes
              HOSTNAME=localhost.localdomain
              GATEWAY=XXX.XXX.XXX.1

      Whate should GATEWAY BE? Is this the "Default Gateway" as shown on the router status screen:  71.59.xxx.xxx or my Router Internet IP?

       
    • Joe
      Joe
      2009-04-02

      Thansk for teh Help!

      I made the changes and ifconfig confirms that the changes work but I still can't get connected.

      The setup file indicates that

      NETWORKING_IPV6=yes, your post says "no".  It doesn't work eitehr way so this is probably not my connect issue but it still needs to be correct?

      I am setting this up on a old server that I use for development and playing around.  I set the Domian on teh Router set up as "Charlie".  I uses No-Ip because I have a dynamic address.  If my NoIp URl is "ken.servehttp.com"  should HOSTNAME=dimdim.localdomain be set to

      dimdim.Charlie
      dimdim.ken.servehttp.com
      or
      dimdim.localdomain

      One last thing. Because I already have an Apache erver using port 80 I am using 8080.  This was not a problem when I set it up the first time?  Is there a change to either of these files to accommodate 8080.

       
    • Mike
      Mike
      2009-04-02

      almost all internet connections are currently IPv4 so you likely don't need IPv6 support.

      I would still leave the HOSTNAME as dimdim.locadomain, it really doesn't matter and it doesn't come into play with the problems you are having.  I like setting it so the bash prompt says the hostname is dimdim.

      This is what I would do for your setup:

      1) run the ./configure-ipaddress.pl with these parameters:

      ./configure-ipaddress.pl   ken.servehttp.com  8080

      2)  forward 8080 from your rotuer/firewall to the 192.168.1.50 IP (or whatever you used)

      3) on your PCs inside your router/firewall add an entry to the c:\windows\system32\drivers\etc\hosts file (or /etc/hosts if unix/linux)

        192.168.1.50    ken.servehttp.com

      4) to test your dimdim by going to http://ken.servehttp.com:8080 from computers inside and outside your router/firewall.