Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#7 v0.2 fails to start (NET4.0 not detected)

v0.2.13
closed-fixed
None
5
2014-09-24
2014-02-22
CSB
No

WinXP, x86, NET 4.0 freshly installed.
I just downloaded and tried dile v0_2_12 , and it failed to start with the message "you must install one of the following versions: .NETFramework,Version=v4.0"

I improvised a fix : I changed the Dile.exe.config file :
sku=".NETFramework,Version=v4.0,Profile=Client"

(I added the ",Profile=Client" part). That seems to have fixed the problem, but I don't really know what I'm doing and this may be a bad solution.

Discussion

  • Petrény Zsolt
    Petrény Zsolt
    2014-02-23

    Hi,

    Sounds like you have the client version of .NET 4 installed (http://www.microsoft.com/en-us/download/details.aspx?id=24872), instead of the full version (http://www.microsoft.com/en-in/download/details.aspx?id=17718). I think the former is slightly smaller because it contains less assemblies.

    If using the client version is working for you then I think it's safe to keep your fix. In fact, I'll test this client profile setting a bit further and if it works well then I'll change the config file for the next version of DILE as well.

    Thanks for letting me know about this issue.

    Regards,
    Zsolt Petreny

     
  • Petrény Zsolt
    Petrény Zsolt
    2014-02-23

    • status: open --> accepted
    • assigned_to: Petrény Zsolt
     
  • Petrény Zsolt
    Petrény Zsolt
    2014-02-23

    • Group: v0.01 --> v0.2.13
     
  • Petrény Zsolt
    Petrény Zsolt
    2014-09-24

    • status: accepted --> closed-fixed