PHP 5 integration

2007-05-08
2012-12-07
  • Karl Dickman
    Karl Dickman
    2007-05-08

    This is an upgrade that I am urgently waiting for, as PHP4 seems to lack support for the DOMDocument object, which makes the editing of XML documents infinitely easier.

     
    • Hi Karl,

      Sorry, another thread without comment :-[

      Fortunately, Dev-PHP (versions 2.x) works with PHP5 :
      Help-file, Auto-completion, Internal-preview, and Xdebug as well.
      I don't know if Dev-PHP works with PHP-GTK 2.0 (based upon PHP5).

      Download Dev-PHP (version 2.x - current one is 2.2.0.300)
      Download a PHP environment, from php.net, wamp, xampp, ...
      Connect this environment to Dev-PHP :
      - Menu Option » General options » Parser
      - Enter the path of an installed php-cgi.exe
      Then it should work.

      Best regards,
      Pierre.

       
  • MBishton
    MBishton
    2007-05-14

    Pierre;

    I followed your instructions but get the following error dialog box. 
    "Access Violation at address ------ in module 'devphp.exe.' Read of address ----."
    Once I close the box, the Dev-PHP internal preview tab sais "Please wait..." and does nothing.
    I installed PHP using the MSI installer. Then I copied the php-cgi.exe file from the php-5.2.2-Win32.zip file. 

    Versions (all just installed):
    Dev-PHP = 2.2.0
    Apache  = 2.2.4
    PHP     = 5.2.2
    MySQL   - 5.0.18

    I am new at this and was trying to set up a complete development environment with the versions indicated above, using your IDE. All the recommended tests for Apache, PHP and MySQL worked. Now all I need is the IDE...

    Thanks for your help in advance.
    Regards, Michael

     
    • Hi Michael,

      > I installed PHP using the MSI installer.
      Ok.
      > Then I copied the php-cgi.exe file from the php-5.2.2-Win32.zip file
      This could be wrong. You don't have to copy any file.

      >> Connect your installed PHP environment to Dev-PHP :
      >> - Menu Option » General options » Parser
      >> - Enter the path of the installed php-cgi.exe
      >> Then it should work.
      Does it work now ?

      Best regards,
      Pierre.

       
  • MBishton
    MBishton
    2007-05-15

    Pierre:

    Thank you for your quick response. Sorry to say that it does not yet work properly.

    When I first installed PHP, I installed it as a SAPI or some such thing. This kind of installation does not seem to put the php-cgi.exe file in the PHP directory. That is why I copied it there myself from the zip file. 
    I uninstalled Apache and reinstalled using all of the installation defaults.
    I uninstalled PHP and then reinstalled as an Apache CGI, using all of the other PHP installation defaults.

    I then did as you instructed above. Now I get an HTTP: 404 error.
    I put the php files in the following location.
    C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\PHP
    Then I edited the local server path to read the same as above. I found this under Menu Option >> Web-Server. When I click on ok, it gives me the following error message:
    "Could not bind socket. Address and port are already in use."
    When I go back to tool at the local server path, it shows what I have entered.

    Any clues?

    Regards, Michael