Dear DL,

Sorry for being verbose, but I try to be as accurate as I can, so
I have some problem with DL and PCMCIA Edimax (with RTL8139) network card.

I have a Debian (3.1) Sarge with a 2.4.27 (!) kernel, and it  works perfectly with that PCMCIA card.  Some Debian sarge output:
uname -a
  Linux fw-1 2.4.27-2-386 #1
lspci
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 02)
0000:00:02.0 VGA compatible controller: Neomagic Corporation NM2160 [MagicGraph 128XD] (rev 01)
0000:00:03.0 CardBus bridge: Texas Instruments PCI1131 (rev 01)
0000:00:03.1 CardBus bridge: Texas Instruments PCI1131 (rev 01)
0000:00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
0000:01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

OK. Now let`s see DL-1.2.14

Base modules needed for PCMCIA to work are
i82365
pcmcia_core
ds

The above three modules are loaded with no error/warning using modprobe.
I also have a 3Com pcmcia network card, so I load its module:

modprobe 3c574_cs

cardmgr... watching two sockets.

And it works perfectly, it gets an IP address from a dhcp server using dhcpcd eth0.

Now let's try to load 8139too, at first an error from lspci>

lspci

pcilib: Cannot open /proc/bus/pci/01/00.0
lspci: Unable to read the standard configuration space header of device 0000:01:00.0
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 02)
00:02.0 VGA compatible controller: Neomagic Corporation NM2160 [MagicGraph 128XD] (rev 01)
00:03.0 CardBus bridge: Texas Instruments PCI1131 (rev 01)
00:03.1 CardBus bridge: Texas Instruments PCI1131 (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 01)

modprobe 8139too
/lib/modules/2.4.35.2/kernel/drivers/net/8139too.o: init_module: No such device
/lib/modules/2.4.35.2/kernel/drivers/net/8139too.o: insmod /lib/modules/2.4.35.2/kernel/drivers/net/8139too.o fail
ed
/lib/modules/2.4.35.2/kernel/drivers/net/8139too.o: insmod 8139too failed
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg

lsmod
Module                  Size  Used by    Not tainted
mousedev                4280   0  (unused)
3c574_cs                9740   1
ds                      7380   2  [3c574_cs]
i82365                 46320   2
pcmcia_core            50688   0  [3c574_cs ds i82365]
ip_conntrack           22432   0  (unused)
p80211                 19140   0  (unused)
lvm-mod                61920   0  (autoclean)
md                     60832   0  (autoclean)
apm                    10640   0  (unused)
loop                   49360   0

So I think You can fix it in the next release.

Thanks

George



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.