Can I use it with JDK 1.5.0 ?

Help
2005-04-05
2012-11-28
  • I'm having some problems running dbmonster.

    Using ANT 1.6.2 with JDK 1.5.0 I get the following error, (but I'm sure alla jars are in the classpath):

    taskdef A class needed by class pl.kernelpanic.dbmonster.ant.DBMonsterTask cannot be found: pl/kernelpanic/dbmonster/ProgressMonitor

    I've got the sources and tried to compile with Maven, obtaining the following error:

    BUILD FAILED
    File...... C:\Documents and Settings\Stefano.THS-SM\.maven\cache\maven-java-plug
    in-1.5\plugin.jelly
    Element... ant:javac
    Line...... 68
    Column.... 48
    Error running jikes compiler
    Total time: 3 seconds
    Finished at: Tue Apr 05 14:30:36 CEST 2005

    Anybody can help me?

    Thank you!

     
    • Piotr Maj
      Piotr Maj
      2005-04-05

      Hello Stefano,

      JDK version should not cause any problem. I think that there is something wrong with classpath, but I cannot be sure until I see your build.xml (maybe you have a typo in the path to dbmonster-core?).
      Make also sure that you have a dbmonster version where ProgressMonitor is present.

      To solve a problem with jikes try to switch to old good javac. Play with build.compiler property.

      best regards,
      piotr maj