#189 DAVMail 4.2.0-2066 doesn't find JAVA 1.7

open
nobody
5
2013-03-26
2013-03-26
Anonymous
No

HI,

i#ve just installed the latest DAVMail version 4.2.0-2066 on Windows 7 64bit. Installation runs fine but when i try to start davmaill64.exe (or one of the
other exe files from the installation directory) I get an erro popup says "A suitable version of Java could not be found on your system, please install java
(64-bit) from ....".
When i check java fro DOS box i get the following:
**************************
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\rspmj>java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)
************************************
I've tried to start as Administrator, but this does'nt help (same error).

Any idea about the reason ?

Thanks a lot,
Joerg

Discussion

  • Reno Ray
    Reno Ray
    2013-05-14

    Hi Joerg,

    I have had the same situation before.
    Please take a look on JAVA envionment variables settings.

    variable name: JAVA_HOME (New creation)
    variable value: C:\Program Files\Java\jdk1.7.0

    variable name: CLASSPATH (New creation)
    variable value:C:\Program Files\Java\jre7\lib

    variable name:path(add ;%JAVAHOME%\bin behind)
    %SystemRoot%;%SystemRoot%\system32;%SystemRoot%\system32\Wbem;%JAVAHOME%\bin

    Hope this could help you solve the problem.

     
  • Lendak Imre
    Lendak Imre
    2013-05-30

    You need a 32 bit version of Java 1.6 to run DAVMail.

    I tried building it with 64 bit Java 1.7 on Windows 7 but failed because the (latest) code references missing sun.* packages.