ML 10.8 CalDav Exchange 2 Notification Center

Help
Pnut
2012-09-10
2013-06-12
  • Pnut
    Pnut
    2012-09-10

    Hi all,

    Upgraded to ML 10.8 and DavMail 4.0 - iCal DavCal account setup flawless. Able to view the Public Exchange 2003 Calendar from work. Which means user + password + path all all correct.

    This all works 100% correct. Until….

    Until I get a notification (for the Public Calendar in question) through the new ML 10.8 notification Center and the second I close or snooze that notification, all goes haywire. I get asked for my password over and over.

    Mind you, if the password weren't correct, I would not have gotten my calendar in the first place. Typing in th epassword does nothing, no errors - If I do type in the wrong password I get a "The server responded with an error" message.

    In short, password is correct. There must be something of a hick up with the notification center and DavMail???

    Anyone that can replicate? Or better anyone that has a solution to this odd behaviour.

    Thanks!

     
  • masteratrus
    masteratrus
    2012-09-10

    Did you have to do anything special to get iCal to work?  I can't get it to update at all - keeps saying it cannot connect to localhost.

     
  • Pnut
    Pnut
    2012-09-10

    For ML 10.8 make sure you update DavMail to version 4. Anything below v 4 is not going to work on ML.

    So I get a connection with version 4 perfectly fine, but as soon as a notification kicks in, bam, password prompts galore.

     
  • masteratrus
    masteratrus
    2012-09-10

    Thanks for the fast response … I'm running Version 4 on ML and still can't get Calendar / Reminders to work.  It keeps telling me it can't connect to localhost.  When you set it what did you enter for your username and address?  Did you use domain/username or just username and for address did you do http://localhost:1080/ or something else?

     
  • Pnut
    Pnut
    2012-09-10

    Hi,

    I used DOMAIN\username as username
    and http://localhost:1080/principals/public/Public_Calendar

    again Public_Calendar is the calendar I need to get access to, so if you are trying to access a public calendar, you will need to know the name. If you are trying to access to a user calendar it would be similar to: http://localhost:1080/principals/users/user@company.com

    P.S. public calendars cannot have spaces in them!!! They won't work - at my work the calendar was once called Public Calendar. They needed to change it to Public_Calendar for it to work for me.

     
  • Pnut
    Pnut
    2012-09-10

    For now it seems a "workaround' appears to work. Set Calendar notifications from Alerts to Banners.

    However still odd that I get the password request when using "Alerts"

     
  • masteratrus
    masteratrus
    2012-09-10

    Thanks for the help, but I still can't get it to connect to the localhost.  It sets up fine, so I know it sees it briefly, but then after that it can't connect to download my calendar events or reminders.

     
  • In Alert mode it's probably trying to update event on the server on Dismiss => as the calendar is readonly you get an authorization error.

     
  • masteratrus
    masteratrus
    2012-09-14

    Would you mind sending me screenshots of your calendar setup in iCal > Accounts.  This would be the Account Information Tab & Server Settings Tab?  I just can't see what I'm doing wrong and it still won't work.

    Also, I'm running 10.8.1 if that makes a difference?