No Private Keys found - Linux Mint

2013-06-11
2013-06-16
  • Hey,

    I'm on linux mint trying to make davmail work.
    I'm getting an exception, when trying to connect

    Thread: CaldavConnection-47979
    Message #: 12
    Level: ERROR
    NDC:
    Category: davmail
    Message: Exchange login exception: Received fatal alert: handshake_failure
    Location: davmail.ui.tray.DavGatewayTray.displayMessage(DavGatewayTray.java:113)
    Thrown:
    davmail.exception.DavMailException: Exchange login exception: Received fatal alert: handshake_failure
    at davmail.exchange.ExchangeSession.<init>(ExchangeSession.java:247)
    at davmail.exchange.ews.EwsExchangeSession.<init>(EwsExchangeSession.java:141)
    at davmail.exchange.ExchangeSessionFactory.getInstance(ExchangeSessionFactory.java:143)
    at davmail.exchange.ExchangeSessionFactory.getInstance(ExchangeSessionFactory.java:94)
    at davmail.caldav.CaldavConnection.run(CaldavConnection.java:167)

    Thread: CaldavConnection-47979
    Message #: 10
    Level: DEBUG
    NDC:
    Category: davmail.http.DavMailX509KeyManager
    Message: No Private Keys found
    Location: davmail.http.DavMailX509KeyManager.chooseClientAlias(DavMailX509KeyManager.java:114)

    Thread: CaldavConnection-47979
    Message #: 11
    Level: ERROR
    NDC:
    Category: davmail.exchange.ExchangeSession
    Message: Exchange login exception: Received fatal alert: handshake_failure
    Location: davmail.exchange.ExchangeSession.<init>(ExchangeSession.java:246)

    Did some debugging and found out, that in
    DavGatewaySSLProtocolSocketFactory.createSSLContext() line: 129
    davmail.ssl.clientKeystoreFile is null. Basically in the settings->Encryption, as I discovered only the davmail.ssl.keystoreFile property gets the value of the keystore file. So, when it continues it'll just carry that null and gives an exception.
    I checked the keystore file of course, and it works flawlessly in windows too.

     
  • Looks like your Exchange server requires a client certificate and you don't provide one...