Backwards compatibility?

Help
EMS
2009-01-07
2013-04-25
  • EMS
    EMS
    2009-01-07

    I'm doing some work on a pre-existing web application that is part of a DACS federation. It appears to be using an outdated version of DACS (it says "V1.2R1.3.2"). It's difficult for me to work with it, as the documentation for that version does not appear to be available any longer.

    If I were to upgrade the DACS installation for our jurisdiction to the latest version, would it still be able to interact with the rest of the federation?

     
    • Barry Brachman
      Barry Brachman
      2009-01-09

      [I posted a reply a few days ago but it never appeared...]

      No one should still be using DACS V1.2.
      But if you really must, I have bundled up the documentation
      that came with it and made it available here:
         http://dacs.dss.ca/old/
      Proceed at your own risk.

      The latest version of DACS will interoperate with V1.2 to a
      limited extent - basically, the new release can understand
      credentials created by V1.2, but not vice versa.  I believe that
      at least one federation has done this successfully.
      The link above will get you started.

      BTW, the next release of DACS is imminent, so I recommend
      waiting to use 1.4.22 instead of 1.4.21.

      Hope this helps.
      Barry