Hello everyone,

I am trying to build the Tradebeans and Tradesoap from the DaCapo source with Java 1.6, Maven 2.1.0 and javacc 4.2.
It seems the source must be compiled with Java 1.5 instead of 1.6. The build error reporting that is shown in Error 1. However,
switching to 1.5 causes another failure, as shown in Error 2. Is there anything else I can do to try and get these 
benchmarks to compile? Thank you for taking the time to read this.

- Diogenes

Error 1:
[exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [INFO] Scanning for projects...
     [exec]      [exec] [INFO] Reactor build order: 
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Schema
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Builder
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Server
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Naming Builder
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Security Builder
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Test DDBeans
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Web 2.5 Builder
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Deployer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: JSR-88 EAR Configurer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: JSR-88 JAR Configurer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: JSR-88 RAR Configurer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: JSR-88 WAR Configurer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Unavailable Client Deployer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Unavailable EJB Deployer
     [exec]      [exec] [INFO]   Geronimo Plugins, J2EE :: Unavailable Web Services Deployer
     [exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [INFO] Building Geronimo Plugins, J2EE
     [exec]      [exec] [INFO]    task-segment: [install]
     [exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [INFO] [enforcer:enforce {execution: default}]
     [exec]      [exec] [WARNING] Rule 0: org.apache.maven.plugin.enforcer.RequireJavaVersion failed with message: Detected JDK Version: 1.6.0-27 is not in the allowed range [1.5,1.6).
     [exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [ERROR] BUILD ERROR
     [exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [INFO] Some Enforcer rules have failed. Look above for specific messages explaining why the rule failed.
     [exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [INFO] For more information, run Maven with the -e switch
     [exec]      [exec] [INFO] ------------------------------------------------------------------------
     [exec]      [exec] [INFO] Total time: 2 seconds
     [exec]      [exec] [INFO] Finished at: Wed Jul 24 15:06:21 EDT 2013
     [exec]      [exec] [INFO] Final Memory: 21M/240M
     [exec]      [exec] [INFO] ------------------------------------------------------------------------

Error 2:
Buildfile: /home/dan/research/benchmarks/build.xml
BUILD FAILED
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:300)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:88)
at javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:278)
at javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:185)
at javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:107)
at org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java:120)
at org.apache.tools.ant.util.JAXPUtils.getNSParserFactory(JAXPUtils.java:104)
at org.apache.tools.ant.util.JAXPUtils.getNamespaceXMLReader(JAXPUtils.java:172)
at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:273)
at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:178)
at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:82)
at org.apache.tools.ant.Main.runBuild(Main.java:793)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)