Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#436 d2x-xl freezes Xorg

Linux
closed-works-for-me
nobody
None
5
2007-03-27
2007-03-10
epsy
No

This happended me many times:
I'm playing a level and i turn/open a door/enter in an area, and all freezes. I can't even crtl+alt+del X, trough i can still connect from another computer and kill d2x-xl, and X gets better again.

I tried to record something from it with gdb or strace from the other display(remotely), but both seemt to not give the correct DISPLAY env var and i got a "couln't set video mode to ...."

Seems happening esp. when the number of visible cubes sightly increases.

I can reproduce this bug easily on D2:CS level 2(the door near the first fuel center), D2:Vertigo level 1(behind one of the 1st doors).

I fond something related on my gfx card with this symptoms, and tried it's fix, but it was the only game where i get it and i still get it...

Discussion

  • karx11erx
    karx11erx
    2007-03-10

    Logged In: YES
    user_id=1402680
    Originator: NO

    Did you set the proper color depth for X? (See the FAQ on www.descent2.de)

     
  • epsy
    epsy
    2007-03-10

    Logged In: YES
    user_id=1498292
    Originator: YES

    Yes i have 24 bits in my cfg but it only happens when i try to launch it from display :1 to display :0

    btw, isn't the main problem...

     
  • karx11erx
    karx11erx
    2007-03-15

    Logged In: YES
    user_id=1402680
    Originator: NO

    I think color depth should be 32 bits.

     
  • epsy
    epsy
    2007-03-19

    Logged In: YES
    user_id=1498292
    Originator: YES

    well, my gpu isn't intended to work on 32 bits mode, only 24 at max(still works "fine" locally)

    i tried, and X simply didn't started ((EE) I810(0): Given depth (32) is not supported by I830 driver)

     
  • karx11erx
    karx11erx
    2007-03-23

    • status: open --> closed-works-for-me
     
  • epsy
    epsy
    2007-03-25

    • status: closed-works-for-me --> open-works-for-me
     
  • epsy
    epsy
    2007-03-25

    Logged In: YES
    user_id=1498292
    Originator: YES

    I think it has something to do with target indicators drawing, maybe when drawed out screen.

    btw idk why did you closed it in a so !§?*% manner.

     
  • karx11erx
    karx11erx
    2007-03-27

    • status: open-works-for-me --> closed-works-for-me
     
  • karx11erx
    karx11erx
    2007-03-27

    Logged In: YES
    user_id=1402680
    Originator: NO

    If you don't reply in a reasonable amount of time, or if the problem is not reproducable, I will close a ticket. You wrote something about i830 gfx, that's an Intel integrated gfx chip, which probably does not fully support OpenGL. Get a dedicated gfx card (cheap one will do).