#2701 [1.17.1] Ship can't fit into small spaces where it should fit

Linux
closed-fixed
nobody
None
5
2014-06-22
2013-10-04
Alter-Fox
No

On version 1.17.1 (for reasons I explained in another bug report I can't test this in version 1.17.2), and for several versions before that, the player ship can't fit into small spaces where it could fit at the time when the Pumo Mines 3 level demo was released. I noticed it first when I was trying to play through the Pumo Mines demo a second time, and on level 3 I couldn't fit under the bridges in any of the main areas (which meant I couldn't, say, get the nucleon cannon), or into the shaft that I needed to pass through to get into the lava cavern with one of the keys. So this also makes the level uncompletable...
I haven't encountered this very much in other missions but that's probably because most missions don't try to make small spaces that you have to fit through. So I'm not 100 percent sure it isn't just Pumo Mines and its custom ship, but I'm 95 percent sure it isn't just Pumo Mines. I haven't been able to build a map to test this myself because I don't know the width of the minimum opening size the regular pyro, phantom, or wolf should be able to fit through.

Related

Bugs: #2701

Discussion

  • TorstenS
    TorstenS
    2013-10-27

    Just wanted to report the same bug. For me it happens in lost levels. I'm still on 1.16.27 (1.17 gives always out of memory error). Played lost levels some years ago with no problem. So, obviously the pyro got too fat over the time. Hope Diedel can give him some diet.

     
  • karx11erx
    karx11erx
    2014-06-16

    I need savegames where the ship is right in front of the area it cannot pass through please.

     
  • TorstenS
    TorstenS
    2014-06-19

    Ok, here two savegames from lost levels (LOSTLVLS.HOG dated 21.1.12), D2xl v.1.16.27. On Level 4 fly into the tunnel and you are stuck. The other one is from level 20, it needs several attemps to pass the door.
    Hope it helps...

     
    Attachments
  • karx11erx
    karx11erx
    2014-06-19

    The mission has a custom ship which seems to be the problem. D2X-XL will compute the actual size of custom models. For geometry collisions, D2X-XL uses a simple collision sphere around an object, the size of which is determined by the largest distance of any two points of the model. Since the custom model has very wide wings, this means that it has a big collision sphere not representing its shape very well and not allowing it to fit through that flat tunnel.

    Other Descent versions may use the standard ship size regardless of the actual (custom) ship's polygon model size and may allow you to pass through that passage.

    I had tried to make D2X-XL use a hitbox for geometry collisions in the past, but this is not trivial due to the physics involved.

     
  • karx11erx
    karx11erx
    2014-06-19

    • status: open --> closed-wont-fix
     
  • karx11erx
    karx11erx
    2014-06-22

    I have looked a bit more into this. The ship's collision sphere's diameter is actually stored in the custom model data (HAM file) contained in the mission. D2X-XL computes it too, and its result is even a bit smaller. However, the problem is not initially caused by D2X-XL. Something I cannot test is whether other Descent versions would use the sphere diameter from the HAM file, or if they would keep using the original Pyro's size.

    Something I might implement is collision ellipsoids. These would enclose flat and/or narrow objects much better and would allow for sufficiently improved geometry collision checking without using hitboxes.

     
    Last edit: karx11erx 2014-06-22
  • karx11erx
    karx11erx
    2014-06-22

    • status: closed-wont-fix --> open
     
  • TorstenS
    TorstenS
    2014-06-22

    Thank you for looking futher into this. One more hint: I'm playing currently with v. 1.15.123 (I had a full backup of it because it ran stable without problems.) The next version I still have is 1.15.260), and there the problem exists. So, somewhere between v 15.124 and 15.260 the problem started. And it's still present in v.1.17.

    Beste Grüsse...

     
  • karx11erx
    karx11erx
    2014-06-22

    Wie gesagt, die Schiffsgröße steht bereits in den Custom-Modelldaten, die der Author der Mission in der Mission hinterlegt hat. D2X-XL verwendet diese Größe für die Kollisionsberechnung. Die Frage ist, ob ältere D2X-XL und andere Descent-Versionen das anders handhaben.

    Was ich versuchen werde ist, Ellipsoid- oder Hitbox-basierte Geometriekollisionen zu implementieren. Das wäre sowieso eine schönere Lösung.

     
    • TorstenS
      TorstenS
      2014-06-22

      Danke, hört sich gut an. Wie gesagt, mit v 1.15.123 hatte es noch funktioniert. Kann man nicht einfach die alte Lösung wieder implementieren?

      Von: karx11erx [mailto:d2x-xl@users.sf.net]
      Gesendet: Sonntag, 22. Juni 2014 16:39
      An: [d2x-xl:bugs]
      Betreff: [d2x-xl:bugs] #2701 [1.17.1] Ship can't fit into small spaces where it should fit

      Wie gesagt, die Schiffsgröße steht bereits in den Custom-Modelldaten, die der Author der Mission in der Mission hinterlegt hat. D2X-XL verwendet diese Größe für die Kollisionsberechnung. Die Frage ist, ob ältere D2X-XL und andere Descent-Versionen das anders handhaben.

      Was ich versuchen werde ist, Ellipsoid- oder Hitbox-basierte Geometriekollisionen zu implementieren. Das wäre sowieso eine schönere Lösung.


      [bugs:#2701] http://sourceforge.net/p/d2x-xl/bugs/2701/ [1.17.1] Ship can't fit into small spaces where it should fit

      Status: open
      Group: Linux
      Created: Fri Oct 04, 2013 08:58 PM UTC by Alter-Fox
      Last Updated: Sun Jun 22, 2014 02:18 PM UTC
      Owner: nobody

      On version 1.17.1 (for reasons I explained in another bug report I can't test this in version 1.17.2), and for several versions before that, the player ship can't fit into small spaces where it could fit at the time when the Pumo Mines 3 level demo was released. I noticed it first when I was trying to play through the Pumo Mines demo a second time, and on level 3 I couldn't fit under the bridges in any of the main areas (which meant I couldn't, say, get the nucleon cannon), or into the shaft that I needed to pass through to get into the lava cavern with one of the keys. So this also makes the level uncompletable...
      I haven't encountered this very much in other missions but that's probably because most missions don't try to make small spaces that you have to fit through. So I'm not 100 percent sure it isn't just Pumo Mines and its custom ship, but I'm 95 percent sure it isn't just Pumo Mines. I haven't been able to build a map to test this myself because I don't know the width of the minimum opening size the regular pyro, phantom, or wolf should be able to fit through.


      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/d2x-xl/bugs/2701/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/


      Diese E-Mail ist frei von Viren und Malware, denn der avast! Antivirus Schutz ist aktiv.
      http://www.avast.com

       

      Related

      Bugs: #2701

  • karx11erx
    karx11erx
    2014-06-22

    Habe ich gerade. ;-)

     
  • karx11erx
    karx11erx
    2014-06-22

    • status: open --> closed-fixed
     
    • TorstenS
      TorstenS
      2014-06-22

      Fantastisch, gerade mal angetestet, funktioniert! Vielen Dank für deine
      Bemühungen!

      Torsten

      Von: karx11erx [mailto:d2x-xl@users.sf.net]
      Gesendet: Sonntag, 22. Juni 2014 20:44
      An: [d2x-xl:bugs]
      Betreff: [d2x-xl:bugs] #2701 [1.17.1] Ship can't fit into small spaces where
      it should fit

      • status: open --> closed-fixed
      • Comment:

      Habe ich gerade. ;-)


      [bugs:#2701] http://sourceforge.net/p/d2x-xl/bugs/2701/ [1.17.1] Ship
      can't fit into small spaces where it should fit

      Status: closed-fixed
      Group: Linux
      Created: Fri Oct 04, 2013 08:58 PM UTC by Alter-Fox
      Last Updated: Sun Jun 22, 2014 02:39 PM UTC
      Owner: nobody

      On version 1.17.1 (for reasons I explained in another bug report I can't
      test this in version 1.17.2), and for several versions before that, the
      player ship can't fit into small spaces where it could fit at the time when
      the Pumo Mines 3 level demo was released. I noticed it first when I was
      trying to play through the Pumo Mines demo a second time, and on level 3 I
      couldn't fit under the bridges in any of the main areas (which meant I
      couldn't, say, get the nucleon cannon), or into the shaft that I needed to
      pass through to get into the lava cavern with one of the keys. So this also
      makes the level uncompletable...
      I haven't encountered this very much in other missions but that's probably
      because most missions don't try to make small spaces that you have to fit
      through. So I'm not 100 percent sure it isn't just Pumo Mines and its custom
      ship, but I'm 95 percent sure it isn't just Pumo Mines. I haven't been able
      to build a map to test this myself because I don't know the width of the
      minimum opening size the regular pyro, phantom, or wolf should be able to
      fit through.


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/d2x-xl/bugs/2701/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/


      Diese E-Mail ist frei von Viren und Malware, denn der avast! Antivirus Schutz ist aktiv.
      http://www.avast.com

       

      Related

      Bugs: #2701