Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

PyNoAppError

Help
2006-01-16
2013-04-17
  • David Jaquay
    David Jaquay
    2006-01-16

    I got an email this past weekend from Ricardocarey saying:

    > Hello. I was interested in trying out your
    > program but i came across a problem when
    > starting it and i have taken a screenshot of it
    > to let you see. Just download my attachment. I
    > have downloaded wxpython 2.3 and python 2.3.2-1
    > and i have installed them both. I have tried
    > numerous times to reinstall it and change
    > folders etc but i can just not get drose.py to
    > open successfully and i dont understand the
    > error message it gives me. It only appears for
    > about a second but i managed to take a
    > screenshot. I have also tried it on another pc
    > and it has the same problem. I also tried newer
    > versions of python and wxpython but they didnt
    > work either. Please help!

    The message was:

    > wx._core.PyNoAppError: The wx.App object must be
    > created first!

    My response:

    > Yes, I got that error when I upgraded to a more
    > recent version of wxpython, and corrected it in
    > the most recent "unstable" version of D-Rose. 
    > (The "unstable" part is the new rail editor; the
    > rest of the program is mostly the same as the
    > latest "stable" release, but with a few
    > bugfixes...)

    (I'm posting this here w/Ricardocarey's permission, in case others are having the same problem.)

    Also, for Windows folks, if you're getting an error like this, but can't read it because the console window vanishes too quickly, you can open up a command prompt and run D-Rose from there; that way, the error message will remain on the screen, and you can cut-n-paste the message into a forum message.

    HTH,
    Dave

     
    • noahdsmith
      noahdsmith
      2007-05-29

      i had the same problem too and im about to try an unstable version

      !!!KEEP GOING WITH THE PROJECT!!!