Problem with (Problema con) CybOrg/DB.pm

Help
hwest
2005-04-14
2013-04-02
  • hwest
    hwest
    2005-04-14

    Hi people, I' m trying to install CybOrg 0.1.19 with Perl 5.8.4, but I have the next error message:
    CybOrg::Exception=HASH(0x84fb8a8)BEGIN failed--compilation aborted at CybOrg/DB.pm line 182.
    Compilation failed in require at /var/www/cgi-bin/cyborg.pl line 30.
    BEGIN failed--compilation aborted at /var/www/cgi-bin/cyborg.pl line 30.

    Well, anybody can help me to fix this problem?
    ------------------------------------------------------------

    Hola, trato de instalar de instalar CybOrg 0.1.19 con Perl 5.8.4, pero me aparece el siguiente mensaje:
    CybOrg::Exception=HASH(0x84fb8a8)BEGIN failed--compilation aborted at CybOrg/DB.pm line 182.
    Compilation failed in require at /var/www/cgi-bin/cyborg.pl line 30.
    BEGIN failed--compilation aborted at /var/www/cgi-bin/cyborg.pl line 30.

    Alguien puede ayudarme para solucionar este problema?

     
    • RazaMetaL
      RazaMetaL
      2005-04-28

      Necesitas instalar DBI 1.2.0 .

      buscalo en CPAN.

       
    • oniat
      oniat
      2005-05-09

      Tengo este mismo problema a pesar de que el cdigo de error es diferentes se produce en los mismos archivos y en las mismas lneas. Segn le en un foro la solucin esta en habilitar tcpip_socket en el archivo de configuracin de la postgresql el problema que tengo es que yo utilizo la versin 8 y en esta versin dicho protocolo ha sido reemplazado por un protocolo llamado listen_addresses el cual tengo habilitado. Pero sigo teniendo el mensaje de error y no me aparece la pantalla de loging del Cyborg. Si alguien conoce el motivo agradecera la repuest dado que tengo un proyecto parado por este motivo. Y me estoy planteando volver a la versin anterior de postgresql.

       
    • oniat
      oniat
      2005-05-09

      Este error lo he solucionado instalando todos los paquetes del tutorial de la siguiente web:
      http://portal.tronk.net/noticia57.html

      Aun asi m da otro error que posteo en un nuevo tema.

       
    • Brad Jensen
      Brad Jensen
      2005-05-10

      Any chance of seeing this tutorial (http://portal.tronk.net/noticia57.html) in English?

      I am having the same difficulty.

      <i>CybOrg::Exception=HASH(0x84fb8a8)BEGIN failed--compilation aborted at CybOrg/DB.pm line 182.
      Compilation failed in require at /var/www/cgi-bin/cyborg.pl line 30.
      BEGIN failed--compilation aborted at /var/www/cgi-bin/cyborg.pl line 30.</i>

      This seems like a major problem with Cyborg.  I have not been able to find a solution that works for me in the forums.  Anybody have any other suggestions?  I would be willing to pay for a solution!

       
      • Brad Jensen
        Brad Jensen
        2005-05-31

        Anybody want to get paid for helping me?  (I can give you ssh access to my server, you won't have to leave your desk!). How much would you be willing to do this for? I have financing and can pay! Help!

        -- Brad

         
    • I have exactly the same problem. I have installed on a RedHat 9 , using perl-DBI-1.32-5. So, I have to downgrade to 1.2.0 to make it work?

       
    • This is my error on apache:

      DB Error:db_connect
      Params:HASH(0x84b6d64)

      CybOrg::Exception=HASH(0x85f631c)BEGIN failed--compilation aborted at CybOrg/DB.pm line 182.
      Compilation failed in require at /datos/www/cgi-bin/cyborg.pl line 30.
      BEGIN failed--compilation aborted at /datos/www/cgi-bin/cyborg.pl line 30.
      [Wed May 11 19:53:09 2005] [error] [client 62.201.1.57] Premature end of script headers: /datos/www/cgi-bin/cyborg.pl
      [Wed May 11 19:53:10 2005] [error] [client 62.201.1.57] File does not exist: /datos/www/internetia/favicon.ico
      [Wed May 11 19:53:10 2005] [error] [client 62.201.1.57] File does not exist: /datos/www/internetia/index.html

       
    • Cheeze
      Cheeze
      2005-06-09

      I had the same problem with line 182 of DB.pm.

      Digging through the forum I found out that the script tries to access the PostgreSQL database in a different way from what you do on your command line.

      You've got to enable tcpip_socket=true (remember to remove the # at the front) and uncomment "port = 5432" as well in postgresql.conf. Restart your postmaster to effect the changes.

      That worked for me. The problem I'm now facing is my login screen does not proceed any further even after I've entered the username and password.

      Can't find the solution at the moment. I would love to write a step-by-step guide for this if I can get it working...

       
      • Brad Jensen
        Brad Jensen
        2005-06-11

        Tried that.  Still no go.

         
    • Cheeze
      Cheeze
      2005-06-11

      Any error messages in the Apache log?

       
    • Fajar Priyanto
      Fajar Priyanto
      2005-06-14

      any error indicating DB_error?
      I have the same problem earlier when I didn't have DBD_Pg perl module installed.

       
    • critters
      critters
      2005-07-03