JXPathException from sources.redhat.com

Help
2006-12-27
2013-04-02
  • Stephen More
    Stephen More
    2006-12-27

    Is there a fix for this problem ?

    <pre>
    ./cvsgrab.sh -url http://sources.redhat.com/cgi-bin/cvsweb.cgi/setup/?cvsroot=cygwin-apps

    CVSGrab - -CVSGrab version 2.2.2 starting...
    CVSGrab - -Detected cvs web interface: hennerik CVSweb $Revision: 1.93 $
    CVSGrab - -cvs update: Updating setup/
    org.apache.commons.jxpath.JXPathException: No value for xpath: TD[1]/A/@name
            at org.apache.commons.jxpath.ri.JXPathContextReferenceImpl.getValue(JXPathContextReferenceImpl.java:344)
            at org.apache.commons.jxpath.ri.JXPathContextReferenceImpl.getValue(JXPathContextReferenceImpl.java:280)
            at net.sourceforge.cvsgrab.web.ViewCvsInterface.getFiles(ViewCvsInterface.java:147)
            at net.sourceforge.cvsgrab.RemoteDirectory.loadContents(RemoteDirectory.java:121)
            at net.sourceforge.cvsgrab.CVSGrab.grabCVSRepository(CVSGrab.java:577)
            at net.sourceforge.cvsgrab.CVSGrab.run(CVSGrab.java:340)
            at net.sourceforge.cvsgrab.CVSGrab.main(CVSGrab.java:232)
    [ERROR] CVSGrab - -Error while getting files from http://sources.redhat.com/cgi-bin/cvsweb.cgi/setup/?cvsroot=cygwin-apps&cvsroot=cygwin-apps
    CVSGrab - ------
    [ERROR] CVSGrab - -There were some errors.
    [ERROR] CVSGrab - -If you cannot find an obvious answer, report the problem to http://sourceforge.net/forum/forum.php?forum_id=174128

    </pre>