2.0.0cvs status API

I've ported the plugin to use the Gaim 2.0.0 status API.

Posted by John Roark 2005-12-17