Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#35 redefine STATUS

open
Anil Kumar
5
2012-10-25
2009-01-16
Anonymous
No

i would like to suggest that "STATUS"-enum
(occurrences in
\Sources\Console\Console.c
and
\Sources\Curses\Curses.c)
should be renamed to CU_STATUS to conform to other CUnit defines and avoid faulty redefines
(e.g. with vxWorks' "types/vxTypesOld.h")

suggestion:
/ Console interface status flag. */
typedef enum
{
CONTINUE = 1, /
< Continue processing commands in current menu. /
MOVE_UP, /< Move up to the previous menu. */
STOP /
< Stop processing (user selected 'Quit').
/
} CU_STATUS;

Discussion


Anonymous


Cancel   Add attachments