#24 cssed-filebrowser-plugin fails to compile

0.4.0
closed-fixed
Iago Rubio
5
2006-12-27
2005-12-21
No

There is an assumption in the configure.in file that plugin.h is installed in
prefix/share/cssed

That's plenty wrong on Mac OS X, where headers should be included in
prefix/include/cssed according to Fink policy.

So, we need a test here to go to the correct directory.

Discussion

1 2 > >> (Page 1 of 2)
  • Iago Rubio
    Iago Rubio
    2005-12-22

    • status: open --> pending-accepted
     
  • Iago Rubio
    Iago Rubio
    2005-12-22

    Logged In: YES
    user_id=910507

    This have been reported in other platforms as well, and it's
    being fixed, the incoming cssed package changes this.

    Those changes on the main package have been commited to cvs
    but the plugins' packages have not been updated yet.

    I must push the changes on the plugins to cvs, as in this
    state the cvs is broken - plugins can't build.

    I'll do it soon.

     
    • status: pending-accepted --> open-accepted
     
  • Logged In: YES
    user_id=552580

    Did you push the changes now?

    Anyway, I've tried cssed from cvs.

    It does not build as is as there is a cs language in the Makefile, whose po file
    is not installed in the po directory, hence the build fails at the end. Removing
    the cs language in the Makefile and updating the pot and po files to latest
    changes makes it compile.

    As far as cssed-file-browser-plugin from cvs is concerned, a patch in the
    Makefile to the right include dir is not sufficient. It fails miserably with:

    callbacks.c: In function 'on_fb_treeview_files_drag_data_get':
    callbacks.c:447: warning: pointer targets in passing argument 4 of
    'gtk_selection_data_set' differ in signedness
    callbacks.c: In function 'fb_treeview_rename_selection':
    callbacks.c:580: error: parse error before 'cannot_msg'
    callbacks.c:587: error: parse error before '}' token
    callbacks.c: In function 'fb_treeview_create_dir':
    callbacks.c:759: error: parse error before 'g_file_test'
    callbacks.c: At top level:
    callbacks.c:765: error: parse error before 'if'
    callbacks.c:776: warning: parameter names (without types) in function
    declaration
    callbacks.c:776: error: conflicting types for 'g_free'
    /Volumes/FireWire3/sw/include/glib-2.0/glib/gmem.h:52: error: previous
    declaration of 'g_free' was here
    callbacks.c:776: warning: data definition has no type or storage class
    callbacks.c:777: error: parse error before '}' token

     
  • Iago Rubio
    Iago Rubio
    2005-12-24

    Logged In: YES
    user_id=910507

    > Did you push the changes now?

    I've just done that now, please try again.

    Remember to rebuild your configure script and Makefiles.

    First make and install cssed from cvs as well, then try it
    out with the cvs plugins.

    If something fails please let me know.

     
  • Logged In: YES
    user_id=552580

    That's exactly the same as before, even if I run automake and autoconf.

    I cannot see any change in cvs for cssed-filebrowser-plugin.

    Did you really change something today? I can only see the changes for cssed you
    made 5 hours ago.

     
  • Iago Rubio
    Iago Rubio
    2005-12-26

    • status: open-accepted --> open-fixed
     
  • Iago Rubio
    Iago Rubio
    2005-12-26

    Logged In: YES
    user_id=910507

    That's fixed now, this files was outdated/broken.

    Please try it again.

     
  • Logged In: YES
    user_id=552580

    The parse errors have vanished, but the signess error is still here as well as the
    error message when creating a new directory, though the directory is creeated.

    callbacks.c: In function 'on_fb_treeview_files_drag_data_get':
    callbacks.c:447: warning: pointer targets in passing argument 4 of
    'gtk_selection_data_set' differ in signedness

     
  • Iago Rubio
    Iago Rubio
    2005-12-30

    Logged In: YES
    user_id=910507

    That's fixed now in CVS, thanks.

     
  • Iago Rubio
    Iago Rubio
    2005-12-30

    • status: open-fixed --> closed-fixed
     
  • Logged In: YES
    user_id=552580

    We are making progress.

    The signess error has vanished, but the message error is still here.

    It is an X11 event, not sure how it can be handled;

     
  • X11 event message when creating a directory

     
    • status: closed-fixed --> pending-fixed
     
  • Logged In: YES
    user_id=552580

    Only to get the mail as it seems my isp is down.

     
    • status: pending-fixed --> open-fixed
     
  • Iago Rubio
    Iago Rubio
    2006-01-02

    Logged In: YES
    user_id=910507

    This error comes from callbacks.c:754 and indicates that the
    directory you're trying to create already exists on the system.

    Is this bogus ?

    The really strange thing about that, is the gtk file chooser
    should not let you to pick and existing directory name.

    I've added some code to show the directory name on the error
    dialog.

    Could you please try it and tell me what directory name
    appears now in the error dialog ?

     
  • Logged In: YES
    user_id=552580

    Yes, this is bogus, the directory does not exist beforehand.

    The error message indicates precisely the name of the directory to create, i.e.
    in this example:

    /Users/michga/tutu

    which does not exist at the time of the creation.

     
  • Iago Rubio
    Iago Rubio
    2006-01-02

    Logged In: YES
    user_id=910507

    I've updated the code to do this check onlt on gtk < 2.4 as
    greater versions don't let you pick and existing file name
    for directory creation.

    Could you please take a test ?

    Thanks in advance.

     
  • Logged In: YES
    user_id=552580

    I've tried it, but it does not change anything.

    So I've added the check for gtk < 2.4 in configure.in (same as in cssed-
    findinfiles-plugin), this time it complains but on the line:

    cssed_plugin_error_message(_("Directory creation error"), strerror(errno));

    Then I've added a flag for Darwin in Makefile.in and change the mode to
    0755, in case it matters (that's the default on Darwin), still the same error as
    above.

    I'm out of idea; maybe the mkdir function is not the right function to use.

     
  • Iago Rubio
    Iago Rubio
    2006-01-22

    Logged In: YES
    user_id=910507

    Could you please send me the output of `man 2 mkdir` on your
    machine ?

     
  • Logged In: YES
    user_id=552580

    Done.

     
  • Iago Rubio
    Iago Rubio
    2006-01-22

    Logged In: YES
    user_id=910507

    Frankly, I'm lost. I don't see where the problem is.

    Could you try to blindly change mkdir for g_mkdir ?

    May be the glib wraper knows how to fix this issue.

     
  • Logged In: YES
    user_id=552580

    I've tried g_mkdir, but I've got the same warning.

    I've tried also the mkdir command in an XCode project, and it works perfectly.

    So, I really think it has to do with errno being changed by different calls. I'm not
    sure that errno is passed unchanged between threads (cssed, cssed-filebrowser-
    plugin). Maybe it would be safer to use a cssed-error.

     
  • Iago Rubio
    Iago Rubio
    2006-12-27

    Logged In: YES
    user_id=910507
    Originator: NO

    I caught this some time ago. The GtkFileChooser was creting the directory itself.

    So it's now fixed.

     
1 2 > >> (Page 1 of 2)