Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#4 Additional plugin to support governor parameters.

closed
None
3
2006-05-16
2006-02-23
Heiko Noordhof
No

This patch is against cpufreqd-2.0.0.

It adds a plugin that supports setting parameters for
the 'ondemand' and the 'conservative' governors in
[profile] sections of cpufreqd.conf.

The patch creates the following new file for the plugin:
src/cpufreqd_governor_parameters.c

and changes the following files:
configure.in
src/Makefile.am

(Note: besides the changes needed to add the plugin
this patch removes some tabs from otherwise empty lines
in src/Makefile.am. I did this because emacs complained
about them saying they were "suspicious
lines")

To apply the patch:
cd cpufreqd-2.0.0
patch -p1 <
/path/to/add_governor_parameters_plugin.patch

To create a new configure script to support the plugin:
# Make sure the (proper versions of) the autotools
are installed,
# then run:
./prepare.sh

To compile with the plugin:
./configure --enable-governor-parameters
make

Need to reinstall to be able to load the added plugin:
su -c "make install"

See comments in the source file of the added plugin
(src/cpufreqd_governor_parameters.c) for details.

Comments, suggestions, patches and bug-reports will be
appreciated.

EOF

Discussion

  • Heiko Noordhof
    Heiko Noordhof
    2006-02-23

    • priority: 5 --> 3
    • assigned_to: nobody --> mattia-san
     
  • Mattia Dongili
    Mattia Dongili
    2006-05-01

    • status: open --> pending
     
    • status: pending --> closed
     
  • Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).