At 5:13 AM -0700 1/27/04, Jason Harris wrote:
Mime-Version: 1.0 (Apple Message framework v609)
Content-Type: multipart/signed; micalg=sha1; boundary=Apple-Mail-12-261628340; protocol="application/pkcs7-signature"
Is the plan to maintain OS X 10.1 support as long as possible?  Does this run on 10.0?

I haven't really thought about it much.  I don't think we're doing anything that really requires any APIs older than yicky old 10.0, so I don't think we need to drop support for older OSes.

I say try to maintain compatibility back to 10.0 but don't go insane about it.  If something comes up that you think will break compatibility, we'll evaluate 'em on a case-by-case basis.

My only real thought on it is that the preference and serialization APIs were dramatically improved in 10.1 and then even more so in 10.2.  Those could be handy, but I don't have a problem continuing using the existing API.  There are also a number of GUI elements that were introduced in 10.1 and 10.2 that could be nice to use.  Does anyone have a 10.0 machine that they can test with?

Jared