How to make it work?


  • Anonymous


    I am a total beginner and totally new to all this with VNC but I am trying to remote administer a friends computer, but I can not get it to work. I have installed OSXvnc 1.33 on my friends computer to be remotely administered, and I have installed chicken 1.3.6 on my computer. Both computers are running OS X 10.3.4. Both computers have the firewall off. Currently both computers are behind the same router, D-Link 614+ wireless router. Internet works fine for both computers at the same time. I have changed the firewall preferences in the router to allow port 5900 to be open for the ip address of my friends computer to be remotely administered. If I ping my friends ip address it works fine, so the ip address seem to be correct.

    The settings for OSXvnc on my friends computer are as follows:
    Display number: 0
    Port: 5900
    Password: ******
    Display name: Someones-Name-Computer.local
    Host Name: Someones-Name-Computer.local
    IP Addresses: ***.***.*.***
    Allow Display Dimming; Ticked
    Allow Machine to sleep: Not ticked
    Swap Mouse buttons 2 & 3: Ticked

    Allow share display between clients: Not ticked
    Let clients decide; Not ticked
    Never share display between clients: ticked
    Keep existing client when new client connects; ticked
    Disable remote keyboard/Pointer: Not ticked
    Only allow local connections: Not ticked

    These are the settings for Chicken 1.3.6:

    Host: ***.***.*.*** (my friends computers ip address)
    Password: ******
    Display (or Port): 0
    Remember password: not ticked
    Shared: Not ticked
    Profile: Default

    Making sure the OSXvnc is running on my friends computer I then click connect on chicken... and I get the following message: "connection refused: connect()"

    Any suggestion on what I should to to make this work?

    Thanks in advance

    • Kurt Werle
      Kurt Werle

      My guess is that you can not reach your friend's machine for some reason.

      1. ping the machine IP address.
      2. telnet machineIP:VNCPort

      You should get a VNC prompt.  If both those things work, but  VNC is still not connecting...  Well, there's a non-network problem.

    • i'd like to chime in on this one...

      i have a normal vnc server (well, an osxvnc server), which i can access using the x-window vncviewer (from realvnc) without problems.  however, when i try the chicken, i get...

      Could not connect to server localhost: 5900
      Connection refused: connect()

      the localhost part is confusing, as i have tried both the dns name and the ip address of the server.

      this is using chicken 2.0b1



      • Jason Harris
        Jason Harris

        Russell, you're running into a problem specific to Chicken 2.0b1.  The issue is that there's no server selected in the box to the left of the connection info, but the bigger issue is that there aren't any default profiles.  Take a look in the Bugs section of this site for (not very easy) workarounds.  Sorry!

    • Jason, thanks for the response.  that was exactly the problem.  though, the "not very easy" workaround was just to click on the "+", and then everything worked.  i had no issues with a missing default profile.

    • Andrew

      I am having the same problem as Russell, except I am running Chicken 2.0b2 and I am selecting the server on the left.

      OS X 10.3.8