#4626 Compiere 3.0/enterprisedb 8.2.5 jdbc error

closed
Felipe Reyes
5
2014-08-16
2008-01-21
symfrog
No

Hi

I am trying to install the latest compiere release (3.0) with an enterprisedb 8.2.5 database.

When I click on "test" at the configuration tab after running RUN_setup.sh, compiere complained with a "ERROR jdbc connection". The error in the logs is as follows:

22:16:05.442 ConfigPostgreSQL.test: OK: Database Server = dbhost/127.0.0.1 [11]
22:16:05.450 ConfigPostgreSQL.test: OK: Database Port = 5432 [11]
-----------> ConfigPostgreSQL.testJDBC: com.edb.util.PSQLException: Backend start-up failed: FATAL: could not open file "global/pg_database": No such file or directory. [11]
-----------> ConfigurationData.test: Error connecting: jdbc:edb://dbhost:5432/edb - as enterprisedb/edb789[11]
===========> ConfigurationPanel.finished: Error JDBC Connection
(Error connecting: jdbc:edb://dbhost:5432/edb - as enterprisedb/edb789) [12]

I have done this several times and have made very sure that the "postgreSQL" option is selected under database type.

I have also tried to connect to the edb database from psql with following result:

# psql -U enterprisedb edb
Password for user enterprisedb:
psql.bin: FATAL: could not open file "global/pg_database": No such file or directory

It seems the edb database does not exist, is there a script that should be run prior to launching RUN_setup.sh when using enterprisedb?

I would appreciated any help.

Thanks

Discussion

  • Felipe Reyes
    Felipe Reyes
    2008-02-04

    Logged In: YES
    user_id=1793135
    Originator: NO

    We are no longer tracking SourceForge requests. Please see this link for details
    http://www.compiere.com/support/community.php

    A connection to the database is a prerequisite to install Compiere. Please ensure that you can connect to the database using psql or Developer Studio before executing RUN_setup

     
  • Felipe Reyes
    Felipe Reyes
    2008-02-04

    • status: open --> closed