Compiere Localizzato - problemi

Robi
2007-08-27
2013-05-02
  • Robi
    Robi
    2007-08-27

    Ciao a tutti,
    ho installato la versione demo di Compiere localizzato per l'Italia da Mayking (jikibloom, 2.5.1x con Oracle 10 xe su WinXPPro sp2, con cui ho caricato il dump MaykingDemo.dmp disponibile).
    All'avvio del client compare, prima ancora del menu, un msg di warning:

    "Errore della versione del Database. Il programma assume che la versione del database sia (0) ma in realtà la versione è (1). E possibile che ciò renda difficile la determinazione degli errori. Si prega di interrompere e di procedere alla migrazione del database"

    ma poi confermando l'OK proposto sembra che l'applicazione sia avviata normalmente e il menu appare con tutte le voci.
    E' un problema che da verificare/sistemare? .. o si può comunque utlizzare Compiere senza problemi di sorta?

    La prima impressione è la seconda, vale a dire che sembra comunque funzionare, cosi ho voluto provare comunque alcune funzioni seguendo i workflow predisposti (per caricare il pdc e il setup iniziale di un Client) per arrivare ai processi e cercare di comprendere le logiche gestite. Tutto sembra funzionare, ma alla registrazione di una fattura fornitore (Italia, con ritenuta) non sono riuscito a completare la transazione, perchè al salvataggio ritorna un errore relativo ad un campo "MAY_ENASARCOAMT" inesistente (nel log è riportato anche un altro campo non presente, "IsIntraCEE").

    Qualcuno ha riscontrato gli stessi problemi? se si, li ha risolti e come?

    Grazie in anticipo
    Ciao

    Robi

     
    • Andrea
      Andrea
      2007-08-28

      Ciao,

      non uso quella versione di Compiere ma il problema e' comunque lo stesso.

      In breve il warning iniziale e' dovuto alla differenza tra la versione che e' mememorizzata nel db (la vedi con 'select version from ad_system') e quella memorizzata nel binario dell'applicazione.
      Se effettui il login impostando in inglese (invece che in italiano) il messaggio di warning sara' completo anche delle due versioni (e noterai l'incrongruenza)
      In funzione di quanto e' cambiato tra le diverse release l'applicazione puo' funzionare o meno, ma io ti SCONSIGLIO FORTEMENTE di lavorare con versioni differenti tra applicativo e db, in quanto rischi di fare danni abbastanza grossi (hai gia' potuto notare che una tabella infatti e' errata e mancano alcuni campi)

      Mi spiace non poterti aiutare oltre ma dovresti interpellare qualcuno di Making :-)

       
    • Suppongo sia dovuto al dump di Oracle. Con PostgreSQL no problem.
      Ciao

       
    • mario
      mario
      2008-06-20

      io all'inizio ho usato una versione di compiere la 2.5.3 con oracle XE (express edition) ed ho incontrato un sacco di problemi ma poi ho cambiato con oracle Enterprise Edition ed ora va tutto bene!
      Comunque ti consiglio di contattare la Mayking
      Ciao