Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Error JDBC Connection

Marc
2006-06-25
2013-05-02
  • Marc
    Marc
    2006-06-25

    kann es sein das dies ein Compiere Fehler ist?
    ./RUN_setup.sh hat immer diesen Fehler!
    sollte doch lauten
    jdbc:oracle:thin:[<user>/<password>]@//<host>[:<port>]/<service>

    Error connecting: jdbc:oracle:thin:@//oracle.office.net:1521/compiere - as system/idiots

    ORA-12514, TNS:listener does not currently know of service requested in connect descriptor
    The Connection descriptor used by the client was:

    http://www.oracle.com/technology/tech/java/sqlj_jdbc/htdocs/jdbc_faq.htm#05_04

     
    • Mat
      Mat
      2006-06-25

      Hi,

      das ist ein typisches Problem, wenn Deine tnsnames.ora nicht ganz sauber ist...

      poste die mal bitte!

       
    • Marc
      Marc
      2006-06-25

      hab's hinbekommen
      und es läuft
      das ganze sid,tns zeug hab ich noch nicht ganz gerafft
      aber man hätte mir auch sagen können das bei
      Oracle Database 10g Express Edition Release 10.2.0.1.0 - Product
      die database XE heissen sollte
      kann wohl nur eine ?!
      na ja ich hätte ja auch mal das manual lesen können
      sqldeveloper & oracle ist schon cool
      schade nur das ich nun ein paar std. mit der installation von compiere "verschwendet" habe :-(
      Mein Fazit: als 4th Dimension & MySQL Fan werde ich wohl nun mehr mit Oracle machen !

       
    • Mat
      Mat
      2006-06-25

      Na.. dann mal zuerst Glückwunsch, dass es soweit geklappt hat.

      Zum Punkt: vier Stunden verschwenden kann ich nur anmerken, dass man sich auch eine fertige Installation kaufen kann :-)

      Im übrigen ist Compiere mit Oracle XE nicht kompatibel und läuft nur mit den Patches von trifon...

       
      • Marc
        Marc
        2006-06-27

        was meinst du denn mit nicht kompatible?
        worin äußert sich das?
        bis dato scheint alles zu laufen?!
        und wo finde ich den patch von trifon?
        danke schon mal

         
    • Mat
      Mat
      2006-06-28

      Hi Marc,

      was meinst du denn mit nicht kompatible?

      - Compiere ist nicht für XE gemacht = nicht freigegegeben = funktioniert nicht einwandfrei!

      worin äußert sich das?

      - es funktioniert nicht alles

      bis dato scheint alles zu laufen?!

      - willst Du Dich im Produktivbetrieb darauf verlassen?

      und wo finde ich den patch von trifon?

      - check the forum!

      danke schon mal

      Bitteschön!