Installation von Compiere

Harald
2006-05-11
2013-05-02
1 2 > >> (Page 1 of 2)
  • Harald
    Harald
    2006-05-11

    Hallo,

    habe Anfang April 5 Tage vergeblich versucht Compiere zu installieren und zum laufen zu bringen und habe den Versuch damals erfolglos abgebrochen.

    Ich würde es gerne nochmals probieren und suche jemanden der mich hierbei unterstützt. Selbstverständlich bin ich bereit dies in gewissen Umfang zu entlohnen.

    Ich freue mich über ein Angebot!

    Tschüss

    Harald

     
    • Oliver
      Oliver
      2006-05-11

      Hallo Harald,

      installierst du von den binaries aus oder arbeitest du mit den sourcecode und möchtest den compilieren.

      Gib doch auch mal einen kurzen Überblick über dein System. (Oracle DB schon installiert ?) An welchem Punkt hast du Probleme ?

      Grüsse,
      oliver

       
      • Harald
        Harald
        2006-05-11

        Hallo Oliver, ich würde mich freuen, wenn du mich unterstützen möchtest. Ich würde von den Binaries aus installieren, aber alles komplett nochmals deinstallieren und von vorne beginnen.

        Probleme gab es wohl mit irgendwelchen POP / SMTP - Servern die ich nicht installiert habe und jetzt zum testen auch nur ungern instalieren möchte, und zum anderen offensichtlich mit dem JBOSS bzw. mit meiner Java 5 -Plattform.

        Wollen wir zusammen von vorne anfangen? Für eine komplette Unterstützung die zum Erfolg führt bin ich gerne bereit er´twas auszugeben!

        Harald

         
        • Oliver
          Oliver
          2006-05-11

          Hallo Harald,

          Mailserver anzugeben ist nicht zwingend. Das hab ich auch nicht gemacht. Und JBoss muss auch nicht laufen. Der ist sozusagen optional. In der Architektur (2-Schichten-Modell) kann die Kommunkation des Client mit der Datenbank über 2 Wege laufen. Zum Einen, und das ist der Standard, geht es über 2-SessionBeans innerhalb des JBoss-Applikations-Server. Wenn dieser nicht vorhanden ist, dann läuft die Kommunikation direkt mit der Datenbank.

          Das einzige was dir dann fehlt, ist die Web-Schnittstelle (sprich der rudimentäre webstore etc), da die innerhalb des JBoss-Tomcat läuft. Ich persönlich lasse auch den JBoss aus, aber ich benutze Compiere auch nicht in einer richtigen Firma, sondern nur privat für meine Diplomarbeit.

          Wenn du JBoss benötigst, dann müssen wir das auch noch prüfen oder der sauber läuft. Wie schauts denn im Moment bei dir aus. Inwieweit sind die Binaries ausgerollt, d.h. in welchem Compiere Verzeichniss liegt alles etc. (Standard wäre ja c:\compiere2). Und ja, ein komplett neu entpacktes Binary wäre sinnvoll, damit wir wirklich von der ursprünglichen Version ausgehen können.

          Und bitte auch noch kurz angeben, welches binary du benutzt. (Exakter Dateiname und Compiere-Version). Die Ausgabe von <java -version> wäre auch gut zu wissen.

          So denn erstmal,
          oliver

           
        • Harald
          Harald
          2006-05-11

          Hallo Oliver,

          ich lade jetzt gerade die Oracle-Datenbank herunter und zwar die Version

          Oracle Database 10g Release 2 (10.2.0.1.0)
          Enterprise/Standard Edition for Microsoft Windows (32-bit)

          Ist das die Richtige?

          Dies wird noch eine Zeit dauern, da ich nur 256 Kbit/s zur Verfügung habe.

          Die alte Datenbank ist gerade dabei deinstalliert zu werden. Ich glaube es war die falsche nämlich die Express-Version!

          Dann werde ich die Oracle-ZIP unter Programme/oracle/ ablegen und entpacken und installieren - mal sehen was passiert. Ich melde mich wenn es Probleme gibt oder wenn ich damit fertig bin.

          Das Web-Frontend von Compiere würde ich mir auch gerne anschauen. Ich möchte Compiere für die Abwicklung eines privaten Projektes benutzen, zumindest wenn es meinen Erwartungen entspricht.

          Tschüss

          Harald

           
          • Oliver
            Oliver
            2006-05-11

            Hallo Harald,

            ja das passt, die 10g hab ich auch drauf. Entgegen der Installationsanweisung von Compiere, kannst du die einfache, d.h. fast autom., Installation laufen lassen. Ich hab die "Standard Version" ausgewählt. Glaub das war die mit 1.1gb oder so.

            Notier dir aber das Passwort ;)

            Wenn du damit fertig bist, musst du wahrscheinlich einmal kurz neu starten, damit die neuen Path-Einträge ziehen. Ach und der öffnet nach der Installation autom. einen browser wo er dich zu einer Seite des Oracle-Web-Dienstes bringt bei welchen du Rechte (3 oder so) vergeben musst. Das also nicht sofort schliessen und alle Rechte vergeben. Dann einmal kurz neustarten...

            dann ist die Umgebungs-Datei von Compiere dran (wenn du es schon entpackt hast). Wie gesagt wäre c:/compiere2  optimal, da standard.
            Du musst also die Datei myEnvironment.bat an deine Umgebung anpassen (db-server name, db-name etc)

            Wenn die Datei noch nicht existiert, einfach myEnvironmentTemplate.bat kopieren in myEnvironment.bat.

            So...viel Glück damit dann erstmal ;)

             
        • Harald
          Harald
          2006-05-11

          Hallo Oliver,

          Download von Oracle läuft noch.

          Wo und welche Version von Compiere soll ich runterladen? Die Version bei compiere.org, die Version bei sourceforge.net oder handelt es sich in beiden Fällen um die gleiche Version 253a?

          Im Internet findet mann noch eine ganze Reihe weiterer Versionen z.B. C253a offenishctlich mit integrierter Datenbank.

          Tschüss

          Harald

           
          • Oliver
            Oliver
            2006-05-11

            Ahm gute Frage...am Besten die von compiere.org würd ich sagen. Ich selbst benutze eh eine alte, die 252e , aber das wird sich ja nicht so herb unterscheiden bei der Installation. Das mit integrierte Datenbank ist mir neu (ausser so VMWare images wie Compuntu wo du ein fertiges Linux (Ubuntu) hast mit DB und lauffähigem Compiere. Aber das ist mehr zum Testen gedacht - jedenfalls nehm ich das eher so zum rumspielen.

            Also 253a von offizieller Seite würd ich sagen...

            oliver

             
            • Harald
              Harald
              2006-05-11

              Ich habe auf der offiziellen compiere.org Seite den Link für den Download nicht gefunden und bin dann auf die Download von sourgeforge.net gegangen und habe festgestellt, dass es mittlerweile eine Version 253b gibt und lade diese gerade herunter. Ich denke aber auch, dass es hier wohl bezgl. Installation keine Unterschiede gibt.

              Ich habe später (17 Uhr) noch eine längere Besprechung und werde nach einer Unterbrechung wohl morgen weiter machen. Wäre nett wenn du auch wieder ins Forum schaust. Für deine Hilfe sollte ja mindestens eine Einladung zum Essen drin sein. In welcher Gegend bist du denn?

              Tschüss Harald

               
              • Oliver
                Oliver
                2006-05-11

                Na klingt doch gut...also ich bin eigentlich fast jeden Tag überwiegend vor'm Rechner und bekomme auch Mails auf alle deine Antworten - werde also nichts verpassen. Morgen bin ich zwischen 12-14:00 Uhr nicht da aber das wird schon.

                Und selber komme ich aus Potsdam...

                So denn bis demnächst also  ;)
                oliver

                 
          • Harald
            Harald
            2006-05-12

            Hallo Oliver,

            die Oracle-DB ist offensichtlich korrekt installiert. Einzige Fehlermeldung war, dass der Server-Rechner die IP-Adresse über DHCP bezieht - hoffentlich ist das kein Problem.

            Compiere ist auch heruntergeladen und entpackt und der Startbildschirm zeigt neben der Console die Standardeinstellungen an. Ist da was zu tun???

            Tschüss Harald

             
            • Oliver
              Oliver
              2006-05-12

              Morgen Harald,

              das mit DHCP hab ich auch so drin gehabt. Mir kracht hier und da die DB zusammen und ist nicht wiederherzustellen. Dann muss ich die immer komplett neu installieren - ohne ersichtlichen Grund. Ist aber möglich, dass meine Festplatte langsam die Hufen hochreisst. Aber wenn das bei dir auch auftritt, dann hat er vielleicht doch damit mehr Probleme als erwartet. Vermute ich aber eigentlicht nicht.

              Mit Startbildschirm meinst du den login-screen von Compiere ?! Nein da ist eigentlich nichts zu tun. Du siehst da nun das Beispiel-Unternehmen Gardenworld. Damit kannst du schon gut rumtesten. Um deine eigene Organisation anzulegen wirst du dich als Administrator (System) einloggen müssen. Sprich als SuperUser und dann die Rolle System Administrator wählen. Von da an ist das für mich auch mehr oder weniger Neuland, da ich Compiere , wie glaub ich schon gesagt, nicht selber im Betrieb nutze sondern damit halt als Entwickler arbeite. Probier mal wie weit du damit kommst.

              Hast du das Handbuch von Compiere ? Das ist über 900 Seiten lang und das wär genau das richtige für dich denk ich. Da geht es um alles was den Anwender interessiert. Dafür ist leider nichts wirklich Interessantes für Entwickler dabei ;)

              Kostet allerdings 60euro oder so. Der Lehrstuhl an dem ich arbeite hat das für mich gekauft gehabt, aber so um den Preis war das. Wäre sicher sehr nützlich für dich. Ansonsten frag wenn was ist und ich werf mal einen kurzen Blick rein.

              Bis dann erstmal,
              oliver

               
            • Harald
              Harald
              2006-05-12

              Hallo Oliver!

              Nein, nein - so weit bin ich noch (lange) nicht.

              Ich RUN_setup.bat gestartet, dann hat sich eine Consule "Install Compiere Server" geöffnet und dann ging ein Fenster "Compiere Server Setup" auf mit vorbelegten Einstellungen.

              Sind diese so beizuhalten?

              Ich warte auf dein OK! Ich glaube hier kann sonst viel Mist passieren - oder?

              Tschüss Harald

               
              • Oliver
                Oliver
                2006-05-12

                Oh ok...

                Also da musst du in der Tat etwas aufpassen.

                Bei JavaHome musst du den Pfad zu deinem JRE1.5 einfügen. Dann natürlich dein Compiere-home - das wäre beim Standard dann c:/compiere2

                Als Applikationsserver wählst du JBoss aus und gibst deinen lokalen Rechner an (JBoss lässt du ja eh erstmal weg soweit ich das verstanden hatte). Die Ports behälst du so bei, es sei denn du hast auf demselben Rechner andere Dienste laufen, die dieselben Ports belegen.

                JNPPort = 1099
                SSLPort = 443
                WebPort = 80

                DBServer wieder dein lokaler Rechner (besser den DNS-Namen nehmen anstatt nur localhost) und als dbtyp dann oracle. Dann gibts du den Namen der Datenbank ein, die du bei der Installation von oracle eingegeben hast. (Standard= "orcl").

                DBPort = 1521

                System-passwort ist dann das, was du während der oracle-installation eingegeben hast.

                Databaseuser und Passwort sind für die Fälle, falls Compiere über einen eingeschränkten, d.h. extra Konto, auf die DB zugreifen soll. Hier nehme ich persönlich auch das "sysman"-Konto und eben wieder das Kennwort der Oracle-Installation.

                MailServer hab ich bei mir wieder auf den lokalen DNS-Namen gesetzt und die restlichen 3 Felder dazu leer gelassen.

                Wenn du das alles eingegeben hast musst du das testen lassen, bevor du speichern kannst.

                Mail-Sachen können ruhig rot angestrichen werden beim Test.

                Nun denn...schaun ma' ma

                 
    • Harald
      Harald
      2006-05-12

      Also:

      den JAVA_HOME-Pfad hat er schon allein richtig gefunden; den COMPIERE_HOME-Pfad habe ich ausgewählt.
      Applikations-Server und Ports klar!
      DB-Server steht der Name meines Rechners drin (wie beim Applikations-Server auch). Name und Port klar!
      Nur User "compiere" und irgendein Passwort steht drin (???)
      Mailserver habe ich so wie du.

      Test: sieht gut aus - Verbindung zur Datenbank steht - Mail-Fehler treten logischerweise auf.

      Gut - ich speichere - Deployment läuft - ist fertig - starte - Anmeldefenster erscheint und bei "Rechner" steht etwas seltsames drin "MyAppsServer{MyDBServer-MyDBName-compiere} - es sieht so aus als würden die Einstellungen aus dem Setup nicht übernommen worden sein ???

      Was tun ? Booten notwendig?

      Tschüss Harald

       
      • Oliver
        Oliver
        2006-05-12

        Das Fenster öffnet sich immer dann, wenn DB/Jboss-Einstellungen fehlen. Gib dann da einfach nochmal die Daten ein und teste in dem Fenster gleich nochmal. JBoss bleibt dann rot, macht aber nix. Nur die DB muss ok sein und dann nochmal compiere starten mit RUN_Compiere2.bat

         
    • Harald
      Harald
      2006-05-12

      Halt stop langsam - welches Febster öffnet sich, wenn DB/JBOSS-Einstellungen fehlen??? das Anmeldefenster öffnet sich dorch wohl in jedem Fall ?!

      Wo soll ich jetzt welche Daten eingeben - im Server-Setup-Fenster - oder? Und welche Daten soll ich da nochmal eingeben?

      Ach - und nach dem Setup muss nochmals RUN_Compiere2.bat gestartet werden ?!?!?!

      So - ich habe jetzt das Setup nochmals aufgemacht und die Einstellungen übereprüft - alles OK! Ich speichere - Deployment läuft - so und im Gegensatz zu vorher starte ich jetzt "RUN_Compiere2.bat" und schaue mal was passiert!

      Kein Unterschied zu vorher! Im Anmeldefenster stehen die gleichen seltsamen Dinge drin! Ich glaube soweit war ich Anfang April aus schon mal.

      Hast du noch eine Idee was ich tun kann?

      Tschüss und mal ein dickes Danke! zwischendurch. Leider ist Potsdam verdammt weit weg von mir. Die Einaldung zum Essen hast du dir schon lange verdient!

      Tschüss Harald
       

      Huuuuuuuuuh! Kapiert hab ichs noch nicht!

       
      • Oliver
        Oliver
        2006-05-12

        Das Fenster was ich meinte war ein anderes als das Setup. Da sind dann nur Einträge für Datenbank und JBoss zu machen. Und das würde eben kommen, wenn noch Daten für die Datenbank fehlen oder die properties Datei (welche durch Setup erstellt wird) gelöscht wurde.

        RUN_Compiere2.bat ist nicht für das Setup wichtig, sondern damit startest du ganz einfach Compiere. Ich  meinte mit nach dem Setup, dass du damit testen kannst, ob Compiere nun hochfährt.

        Leider wiess ich im Moment nicht, was du mit Anmeldefenster meinst. Könntest mir ja mal einen Screenshot von machen und ab das Ding an: 1beast <at> web.de

        dann seh ich auch gleich mal deine Einstellungen...also ruhig von allem mal ein Screenshot schiessen.

        Und mit dem Essen macht nix...bin eh schon zu dick ;)

        nun denn

         
    • Harald
      Harald
      2006-05-12

      OK - ich schau mal wie ich zu Screenshots komme - ich glaube mit "DRUCK" und dann in PSP "EINFÜGEN" kann ich welche abspeichern und schicken.

      Habe jedoch noch eine andere Idee der möglichen Fehlerursache: der Datenbank-User steht im Setup mit compiere drin und irgendein Passwort. Dieser ist ja wohl gar nicht in der Datenbank angelegt! Also sollte ich in Oracle mal einen Benutzer "compiere" anlegen und ein Passwort vergeben und dieses dann im Setup eingeben. Wenn ich die Consoleausgabe nämlich genau betrachte wird gemeldet, dass mit dem User compiere keine Datenbankverbindung hergestellt wird!
      Bei dir funktoniert es ja auch nur mit SYSTEM und Oracle-System-Passwort - nicht wahr?

      Darf jetzt noch schnell einkaufen gehen!

      Tschüss bis später Harald

       
      • Oliver
        Oliver
        2006-05-12

        ja klar...das meinte ich ja mit dem DB-Konto. Ich benutze als username "sysman". Das ist ein Standard-Konto von Oracle (wie Administrator in Windows) mit alles nötigen Rechten. Kennwort ist dann das, welches du im Setup von Oracle angegeben hattest.

        Das sollte dann auch gehen...jedenfalls er DB-Zugriff ;)

         
    • Harald
      Harald
      2006-05-12

      Hallo Oliver,

      ich habe dir per Email einen Screenshot der wesentlichen Fenster zukommen lassen.

      Mittlerweile war das Compiere System so korrupt, dass kein Fenster mehr aufging . . . ich habe also alles gelöscht und von vorne installiert . . .
      ich habe auch die Variante mit dem Database User compiere auf system mit dem entsprechenden Passwort probiert - auch das hat nicht funktioniert.

      Warum steht in der Zeile Rechner des Anmeldefensters diese seltsame Zeichenkette ??? Ich glaube dies ist der Schlüssel zur Problemlösung.

      Werde jetzt wohl in Kürze schlafen gehen und morgen nachmittag so gegen 16 Uhr weiter machen (habe morgen Weiterbildung . . .)

      Hast du noch eine Idee wie es geht???

      Tschüss un gute Nacht Harald

       
    • Stan
      Stan
      2006-06-25

      Hallo Leute,
      versuche grade Compiere zu installieren. Für die Oracle DB gab es eine schöne step by step description für Java nicht. Ich habe java_ee_sdk-5-windows.exe mir heruntergeladen 126mb. Jedes mal wenn ich auf RUN_setup.bat gehe, sagt er ERROR JAVA HOME in dem Ordner jre1.5.0_06 konnte er tools.jar nich finden. Kann mir jemand helfen?
      LG aus Berlin

       
      • Oliver
        Oliver
        2006-06-25

        Hallo,

        JAVA_HOME ist auf das richtige Verzeichniss gesetzt ? die tools.jar sollte im /lib Verzeichniss liegen. Wieso installierst du nicht einfach JDK1.5 ? JavaEE 5 hat ja noch den AppServer den du ja nicht brauchst. Compiere bringt ja JBoss mit.

        Grüsse,
        oliver

         
1 2 > >> (Page 1 of 2)