Compiere 2.6.1 with EnterpriseDB

2007-05-03
2013-05-02
  • A number of you have been eager to begin using Compiere with EnterpriseDB and we would like to help you get started!  We request you to use Compiere Release 2.6.1 for this purpose.

    All issues and bugs should posted to this forum with the subject prefix of "EDB".  Several Compiere developers will be monitoring this forum closely to field the issues identified. 

    Instructions:

    Windows

    1.         Install Enterprise DB 8.1

      a.       Download http://www.enterprisedb.com/products/download.do

      b.       Run the installer as ‘Administrator’, or the one in ‘Administrators’ group

      c.       Choose 'Redwood' compatible configuration and Unicode in install

    2.         Down load source from svn, customize myEnvDev.bat and  run RUN_build.bat, or Down load Compiere nightly build, unzip the package

    3.         RUN_setup.bat,

      a.       On “Database Type” choose “postgreSQL”

      b.       On “Database Path” type in the EnterpriseDB installed path

      c.       On “System Password” type in database system user  “enterprisedb” password

      d.       On “Database Password” type in database user “compiere” password

    4.         RUN_ImportCompiere.bat, note it will create database “compiere” and database user “compiere”, wipe out existing one if any. Ignore the warning messages and the drop error messages.

    5.         RUN_Compiere2.bat. Ignore the database version warning at this point

    UNIX / Linux

    1.         Install Enterprise DB 8.1

      a.       Download http://www.enterprisedb.com/products/download.do

      b.       Run the installer as “root”

      c.       Choose 'Redwood' compatible configuration and Unicode in install

    2.         Down load source from svn , customize myEnvDev.sh and  run RUN_build.sh, or Down load Compiere nightly build, unzip the package

    3.         Run RUN_setup.sh,  > sh RUN_setup.sh

      a.       On “Database Type” choose “postgreSQL”

      b.       On “Database Path” type in the EnterpriseDB installed path

      c.       On “System Password” type in database system user  “enterprisedb” password

      d.       On “Database Password” type in database user “compiere” password

    4.         RUN_ImportCompiere.sh, note it will create database “compiere” and database user “compiere”, wipe out existing one if any Ignore the warning messages and the drop error messages.

    5.         RUN_Compiere2.sh. Ignore the database version warning at this point

    NOTE When EnterpriseDB creates a database user, it will also automatically create a user in the operating system. 

    Thanks,
    Sunny

     
    • edwin
      edwin
      2008-03-05

      Dear Sunny,
      I've tried to install Compiere 2.6.1 with postgres 8.2 on WindowsXP for many times. When I started to run RUN_SETUP.BAT, I always got with same problem/error message (see below). Could you please help me out? Thank you very much.

      Cheers,
      Edwin

      Log from RUN_SETUP.BAT process:

      Starting Setup Dialog ...

      *** 2008-03-05 06:22:01.311 Compiere Log (CLogConsole) ***
      06:22:01.311   CLogMgt.setLevel: CONFIG
      06:22:02.383 Setup.<init>: Compiere(r) Release 2.6.1_2007-04-27 - Smart ERP & CR
      M - (c) 1999-2007 Compiere (r); Implementation: 2.6.1 20070427-1153 - ComPiere,
      Inc.
      06:22:02.673 ConfigurationData.load: Defaults
      06:22:21.911 Config.test: OK: JavaHome=c:\program files\java\jdk1.5.0_12 [11]
      06:22:21.911 Config.test: OK: Version=1.5.0_12 [11]
      06:22:21.911 ConfigurationData.testCompiere: OK: CompiereHome = D:\Compiere\Comp
      iere2 [11]
      06:22:21.921 KeyStoreMgt.<init>: D:\Compiere\Compiere2\keystore\myKeystore [11]
      06:22:21.981   KeyStoreMgt.getCertificate: Alias=compiere [11]
      06:22:21.991 ConfigurationData.testCompiere: OK: KeyStore = D:\Compiere\Compiere
      2\keystore\myKeystore [11]
      06:22:21.991 Config.test: OK: AppsServer = nawi/127.0.0.1 [11]
      06:22:22.021 Config.test: OK: Deploy Directory = D:\Compiere\Compiere2\jboss\ser
      ver\compiere\deploy [11]
      06:22:23.002 Config.test: OK: JNPPort = 1099 [11]
      06:22:24.995 Config.test: OK: Web Port = 80 [11]
      06:22:26.197 Config.test: OK: SSL Port = 443 [11]
      06:22:26.197 Config.test: OK: Database Server = nawi/127.0.0.1 [11]
      06:22:26.217 Config.test: OK: Database Port = 5432 [11]
      -----------> Config.testJDBC: com.edb.util.PSQLException: Backend start-up faile
      d: FATAL: database "edb" does not exist. [11]
      -----------> ConfigurationData.test: Error connecting: jdbc:edb://nawi:5432/edb
      - as enterprisedb/password [11]
      ===========> ConfigurationPanel$1.finished: Error JDBC Connection
      (Error connecting: jdbc:edb://nawi:5432/edb - as enterprisedb/password) [12]