Install question re JAVA file needed

2008-08-18
2013-05-02
  • Hi,
    I've downloaded and installed Oracle XE without problems, following the instructions posted on the Compiere web site.  The next step says "Download and install SUN Java 1.6.0(SDK) - also known as SunJava JDK, Update 12, or a later version of Java 1.5."   The quetion is, what is the exact filename I'm supposed to download and install?  I looked several places on the Sun website but could not find the aforementioned file.  So I downloaded J2SE Runtime Environment 5.0 Update12.  (and installed it before thinking.) Is that file adequate? Will it cause problems with the download or install of Compiere 3.1 ?

    Thank you!

     
    • Kathy Pink
      Kathy Pink
      2008-08-18

      you need version 6 (and you should get update 7 as that is the latest).  Compiere 3.1 will not run with version 5.  The exact file is dependant upon your operating system.  But you should be able to get it from the following link
      http://www.java.com/en/download/
      Thanks for the catch on the install instructions.  THey are being updated

       
    • Steven Levine
      Steven Levine
      2008-08-25

      I've installed  JDK 6 Update 7 with Java EE.

      When I execute the script $COMPIERE_HOME/RUN_Setup I get the Compiere Server Setup window.  I enter my server names, etc. and click test and get one error.

      The error is that it cannot locate the "tools.jar" in C:\Program Files\Java\jre1.6.0_07\lib.  I checked this folder and the "tools.jar" is not present.

      The JAVA installation also created a path of C:\Sun\SDK\jdk\lib, which does contain the "tools.jar" file.  I tried changing the path for JAVA_HOME in the Compiere Server Setup window to C:\Sun\SDK\jdk\lib and I now get an error message that this is the wrong version of JAVA.

      Any suggestions?

      Thank you!

       
      • Felipe Reyes
        Felipe Reyes
        2008-10-03

        It seems like you set your JAVA_HOME to point to JRE (C:\Program Files\Java\jre1.6.0_07) instead of JDK, and you must use JDK to install Compiere.

        Try updating your environment variable JAVA_HOME to C:\Program Files\Java\jdk1.6.0_07
        To update the JAVA_HOME on Windows, right click on My Computer and choose Properties. Go to the advanced tab and click on Environment Variables. Find the JAVA_HOME variable and click Edit
        and use the same value in RUN_setup.

        If you don't have a folder jdk1.6.0_07, then you need to download and install JDK 6 Update 7
        http://java.sun.com/javase/downloads/index.jsp

         
    • Dan Whelan
      Dan Whelan
      2008-10-03

      This is exactly what's happening to me as well.

      I also have the JDK 6 Update 7 with Java EE and exactly what Steven describes above is what is happening when I try to install Compiere.

      Amazingly enough, I'm also wondering if anyone has any suggestions.

      Thanks in advance.

       
    • Kathy Pink
      Kathy Pink
      2008-10-03

      I have 1.6 update 6 installed and the tools.jar file is in Program files\Java.... 
      Have you tried copying the tools file to that directory from the Sun one?

       
    • Dan Whelan
      Dan Whelan
      2008-10-03

      It seems like copying the file tools.jar file to the directory worked.

      I copied it to C:\Program Files\Java\jre1.6.0_07\lib and seem to have fixed that error.

      Now it says the  JNP Port is wrong. It's set to 1099... I have no idea what the JNP Port id. Did I install the JNP Port? What's it supposed to be?

       
    • Kathy Pink
      Kathy Pink
      2008-10-06

      YOu need to use the JDK not the JRE.  YOur java home should point to the JDK directory